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Chapter I
Chapter I

Getting Started

Opto 22 and SNAP PAC System Products
Founded in 1974, Opto 22 develops and manufactures hardware and software products for 
applications in industrial automation, remote monitoring, data acquisition, and the 
Industrial Internet of Things (IIoT). Using standard, commercially available Internet, 
networking, and computer technologies, Opto 22’s input/output and control systems allow 
customers to monitor, control, and acquire data from all of the mechanical, electrical, and 
electronic assets that are key to their business operations. Opto 22’s products and services 
support automation end users, OEMs, and information technology and operations 
personnel. More than 85 million devices worldwide are reliably connected to Opto 22 
systems.

Opto 22’s SNAP PAC product family provides systems for remote monitoring, data 
acquisition, industrial automation, and IIoT applications. The choice of system varies 
according to application needs, for example, the level of control, network and 
communication protocols, mobile access to data or control, and requirements for 
integration with other systems and equipment.
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SNAP Products Overview
Opto 22 provides a diverse set of products used for many purposes. 
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I/O Unit 
The I/O unit is the essential combination of inputs and outputs wired to real-world devices, 
plus an I/O processor (on-the-rack controller or brain) for local intelligence and 
communication. You can build a variety of I/O units to match your needs.



OPTO 22 AND SNAP PAC SYSTEM PRODUCTS

SNAP PAC Learning Center User’s Guide4

PAC Project Software Suite
Opto 22’s PAC Project software suite is an integrated set of software and utilities for use with SNAP 
PAC systems. Collectively, these tools provide a simple yet powerful way to configure, design, and 
troubleshoot your control environments.

PAC Control Basic (included with this Learning Center):

• PAC Control™ Basic

• PAC Display™ Basic

• PAC Manager™

PAC Project Professional (available for purchase):
• PAC Control Professional

• PAC Display Professional

• OptoOPCServer™

• OptoDataLink™

• SoftPAC™

• PAC Manager

PAC Control—The SNAP PACs are programmed using PAC Control, a graphical, flowchart-based 
programming tool for machine control and process applications. Using PAC Control, you create, 
download, and run control programs. In addition to flowchart programming, PAC Control includes a 
powerful, built-in scripting language based on C and other procedural languages.

PAC Display—Opto 22’s PAC Display is an intuitive HMI package for building operator interfaces for 
your Microsoft® Windows®-based clients communicating with Opto 22 SNAP PAC systems. 
PAC Display offers a full-featured HMI including alarming, trending, and a built-in library of 3,000 
industrial automation graphics.

PAC Manager—PAC Manager is a maintenance and configuration utility provided with SNAP PAC 
systems hardware. This utility sets up the Ethernet communications, upgrades firmware, and 
streamlines the configuration of the I/O unit.

OptoOPCServer—OptoOPCServer is a fast, efficient OLE for Process Control (OPC) 2.0-compliant 
server that provides OPC clients access to SNAP PAC systems. Client applications can read and write 
to I/O points or even change their specific configuration options. OPC clients also have access to all 
strategy variables and elements in a PAC Control strategy.

OptoDataLink—OptoDataLink is connectivity software that collects data from an Opto 22 SNAP 
PAC controller and other sources, and then sends that data to one or more destinations. 
OptoDataLink supports sending data to ODBC-compliant databases, SNAP PAC controllers and 
brains, and ASCII text files.

SoftPAC—A software-based controller for PC-based control, SoftPAC runs on 

PAC Project Basic™ provides all the software you need for industrial automation, remote monitoring, 
and data acquisition applications in any field. During this course, you’ll use components of PAC 
Project Basic. However, you’ll want to use PAC Project Professional™ for operations that include 
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complex network architectures, ODBC database connections, redundant controllers, OPC 
communication, or legacy Opto 22 FactoryFloor® systems. 

SNAP PAC Learning Center Guide
This SNAP PAC Learning Center Guide is a hands-on, learn-by-example training course. Each 
chapter introduces aspects of PAC Control, PAC Display, and PAC Manager with a 
step-by-step guide.

What You Will Do
• Introduction: Assemble the Learning Center hardware.

• Lesson 1: Establish network communication with your PAC system using PAC Manager.

• Lessons 2–6: Configure the I/O and program the SNAP PAC using PAC Control.

• Lessons 7–9: Create an operator interface using PAC Display.

Learning Scenario: Convenience Store
Lessons 1–9 present their concepts within the context of a fictional scenario: using a SNAP 
PAC R-series I/O unit to remotely control and monitor a convenience store. The SNAP PAC R 
is ideal for many types of applications, but a convenience store example allows us to 
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demonstrate the rich set of features that combines aspects of machine control, monitoring, 
and data acquisition.

In this example, you will learn how to connect and control machinery, program logic using 
simple flowcharts and user-friendly project management, and create sophisticated user 
interfaces. These activities will illustrate how you can control many types of processes or 
monitor any type of machinery, and create complex process visualization programs.

Lesson Format
The following sections are used to assist you in learning, reviewing, and applying the 
material:
• Skills—an overview of skills taught in the lesson.

• Scenario—a description of how the lesson affects the convenience store application being 
built throughout the course.

• Concepts—an overview of the background concepts being applied in this lesson.

• Activity—step-by-step procedures and explanations for building the convenience store 
application, interspersed with concept reviews. Instructions within the activity should be 
followed exactly. In some instances, upper or lowercase letters must be used. Type variable and 
I/O point names exactly as shown in this manual.
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• Project Road Map—the Road Map provides an overview of all the features covered in this 
Learning Center Guide. This may help you keep track of your progress and know where to 
review. It also shows you which features affect later chapters. For example, the Road Map 
shows you which points configured in previous chapters are used in later chapters.

Lesson Conventions
The following conventions are used throughout this guide:
• Menu commands: Select File > New to create a new file.

• Computer files: Open the file Store_IOConfig.otg.

• Text that you are to type: Fuel is low

• Named selections on the screen: In the Type field, choose Analog Point.

• Graphic illustrations of software: 

– Curved arrows show preceding step(s).

– Straight arrows emphasize a feature of interest.

SNAP PAC Learning Center Supplements
When you’ve completed the activities in this SNAP PAC Learning Center Guide, there is still 
more to discover. Learning Center Supplements (OptoTutorialsTM) provide step-by-step 
instructions for advanced features of PAC Project software. To download the latest 
OptoTutorials, visit www.opto22.com/site/le_index.aspx.

This diagram is an example of the type of 
instructions used throughout this guide.



WHAT YOU NEED

SNAP PAC Learning Center User’s Guide8

What You Need

System Requirements
To use the SNAP PAC Learning Center with your PC, you must have the following minimum 
computer configuration for PAC Project software: 
• A computer with a standard or mainstream core processor and (at least) the minimum memory 

required for your version of Microsoft Windows. (Low-end CPUs are not recommended.) 
Additional memory may be required for some configurations. 

• One of the following operating systems:

– Microsoft Windows 10 Professional (32-bit or 64-bit)

– Windows 8.1 Professional (32-bit or 64-bit)

– Windows 7 Professional (32-bit or 64-bit)

– Windows Vista® Business (32-bit only)

NOTE: PAC Project will not install on Windows XP or older Windows operating systems. Embedded 
operating systems are not tested or supported. 

• Ethernet capability.

• VGA or higher resolution monitor (Super VGA recommended). Minimum size: 800x600 with 
small fonts.

• Mouse or other pointing device.

• (Optional) Installed Windows printer.

• For available hard disk requirements, please see the PAC Project Release Notes.

Installing the SNAP PAC Learning Center Software
You will use the PAC Project Basic Software Suite with the SNAP PAC Learning Center. 
1. Open the SNAP-PAC-R1 package that came with the Learning Center and remove the PAC 

Project CD. Insert the CD in your computer’s CD drive.
2. If the installation wizard does not appear, start Windows Explorer, navigate to your compact 

disc drive, and double-click Setup.exe to begin installation.
3. Follow the on-screen instructions. During installation, make the following choices:

– When asked to choose between PAC Project Basic and PAC Project Professional, choose PAC 
Project Basic.
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– In the Select Components dialog box, make sure Install Learning Center Files is checked, as 
shown here:

The following software is installed:

– A complete, fully functional version of PAC Project Basic software and utilities

– Learning Center sample files, which are installed in the SNAP PAC Learning Center 
directory. For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC 
Learning Center

NOTE: Your PAC Project version number may be different.

If you have trouble installing the software, contact Opto 22 Product Support. See “Product 
Support” on page 4.

Setting up the SNAP PAC Learning Center
The SNAP PAC Learning Center includes all the necessary Opto 22 I/O hardware, a load 
panel with power supply, and all necessary cables.

SNAP Hardware Components

SNAP PAC R

The SNAP PAC R is one of Opto 22’s high-performance I/O processors with an on-board 
control engine designed to control analog, digital, and serial modules on the same rack. 

The SNAP PAC R merges two functions that are usually located in separate pieces of 
hardware: input/output processing and flowchart-based control. The processor, rack, and 
modules together are referred to as an I/O unit. You can attach the I/O unit to existing 
Ethernet networks, making it easy to add control where necessary. Or you can use standard 
Ethernet connections to build an independent control network, connecting your PC 
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directly to the I/O unit. With a SNAP-PAC-R-W Wired+Wireless controller you can use either 
a standard Ethernet network or a wireless LAN.

SNAP-PAC-RCK8 Rack

The SNAP-PAC-RCK8 rack mounts up to eight SNAP digital, analog, and serial modules.

SNAP I/O Modules

The Learning Center includes the following SNAP I/O modules:
• SNAP-IDC5D: Digital DC Input 2.5–28 VDC, 5 VDC Logic

• SNAP-ODC5SRC: Digital DC Output 5–60 VDC Source, 5 VDC Logic

• SNAP-AOV27: Analog Output Dual -10 to +10 VDC

• SNAP-AICTD: Analog Input Dual ICTD Temperature

• SNAP-AIV: Analog Input Dual ±10 or ±5 VDC 

Learning Center Load Panel
The load panel consists of:
• Two toggle switches

• Two momentary switches

• One SonAlert (buzzer)

• Three LEDs

• One meter

• One potentiometer

• Temperature sensor connection

Accessories
The SNAP PAC Learning Center includes the following accessories:
• Temperature probe

• Power cable— Input voltage range for the Learning Center is 120–300 VAC. A power cable is 
included based on your location (U.S., international, or UK). If you find that the cable you have is 
incorrect, please call Opto 22 at 800-321-6786 (toll-free in the U.S.) or 951-695-3000 to request 
the correct one. 

• Ethernet Category 5 cable—This cable allows a direct connection between your PC and the 
SNAP PAC I/O unit without the need for a hub or additional cables.
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Learning Center hardware components are illustrated below:

SNAP rack extrusion SNAP-PAC-RCK8 rack Learning Center load panel

SNAP-PAC-R1 or SNAP-PAC-R1-W SNAP I/O module (5)

Temperature probe SNAP module tool Ethernet cable
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Required Tools
Phillips and flat-blade screwdrivers are provided for assembling the SNAP PAC Learning 
Center. 

Assembling the SNAP PAC Learning Center
Follow the instructions in each section below to assemble the components of your SNAP 
PAC Learning Center and connect it to your PC.

Installing the SNAP-PAC-RCK8 Rack
1. Align the four mounting holes on the Learning Center and the extrusion, and then attach the 

extrusion to the Learning Center using the screws provided.

2. With the release notches at the top, insert the bottom edge of the circuit board into a groove in 
the extrusion.
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3. Insert a flat blade screwdriver into the release notch on the left and pry out the extrusion while 
pushing down hard on the circuit board to push the left edge into place. While maintaining 
downward pressure on the circuit board, pry out the extrusion at the middle release notch and 
push the middle part of the board into place. Continue the process with the right release notch, 
applying hard downward pressure until the circuit board snaps into place. 

4. Attach the end caps with the screws provided.

Release notch

Insert board in groove
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Your rack and extrusion assembly should now look like this:
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Connecting the Power Supply
1. Locate the wire harness behind the load panel of the Learning Center.
2. Locate the red, black, and green wires that have bare leads at one end.
3. On the SNAP-PAC-RCK8 rack, connect the red wire to the +5V connection and tighten its screw 

on the power connector as shown below.
4. Connect the black wire to the -5V connection and tighten its screw.
5. Connect the green wire to the ground connector and tighten its screw.

Power connector screws

Red wire(s)

Black wire(s)

Green wire(s)
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Installing the SNAP PAC Controller
1. Remove the SNAP PAC controller from its packaging.
2. Align the controller’s connector with the mating connector on the SNAP rack as shown here.

3. Seat the controller onto the connector.
4. Tighten the hold-down screw to secure the controller in position.

CAUTION: Do not overtighten the hold-down screw. Doing so may damage the connector, the controller, 
or other components on the SNAP rack.
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Installing the SNAP I/O Modules
1. Remove the five SNAP I/O modules from their packaging. 
2. Starting with SNAP-IDC5D, position the module over the connector, aligning the small slot at 

the base of the module with the retention bar on the rack.
3. Push straight down on the module to snap it into position.

When positioning modules next to each other, be sure to align the male and female module 
keys (shown in the detailed view in the illustration below) before snapping a module into 
position.

4. Repeat steps 2 and 3 for each of the remaining modules.

Your Learning Center should now resemble the illustration below. If a module is positioned 
incorrectly, remove it (see “Removing a SNAP I/O Module” on page 18), and then reinstall it.

Module keys 
correctly aligned

Retention bar
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Removing a SNAP I/O Module
If you insert a module in the wrong location, use the SNAP module tool to retract and hold 
the release latch. Then pull straight up on the module to remove it.

SNAP-AIV
SNAP-AICTD

SNAP-AOV-27
SNAP-ODC5SRC

SNAP-IDC5D

SNAP-PAC-R1
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Connecting the SNAP Modules to the Wiring Harness
The screw terminal connectors are arranged in the order they attach to the modules.
1. Plug the first connector into the first module, the SNAP-IDC5D.

2. Plug in the remaining connectors in order.
3. Check the connections using the following table.

SNAP Module Wire Colors for Corresponding Connector on Wiring Harness

SNAP-IDC5D red, brown/white, red/white, orange/white, yellow/white

The SNAP module tool provides leverage to push out the 
spring-loaded module release latch, which releases the 
module from the retention bar.
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Connecting the Temperature Sensor
The temperature sensor is the cable approximately 3 feet (1 meter) in length with a black 
plastic tip at one end.
1. Using the alignment notch on the connector, plug the temperature sensor into the jack on the 

front left-hand side of the Learning Center load panel.

2. Tighten the threaded collar.

Connecting the Power Cable
To connect the power cable to the SNAP PAC Learning Center, plug the cable into the 
power cord connector located on back of the Learning Center base. 

Input voltage range for the Learning Center is 120–300 VAC. A power cable is included 
based on your location (U.S., international, or UK). If you find that the cable you have is 
incorrect, please call Opto 22 at 800-321-6786 (toll-free in the U.S.) or 951-695-3000 to 
request the correct one. 

NOTE: Don’t turn on the Learning Center until instructed to do so in the next chapter.

SNAP-ODC5SRC red, red, green/white, blue/white, purple/white, gray/white

SNAP-AOV-27 orange, yellow, green, blue

SNAP-AICTD gray, purple

SNAP-AIV white, black

SNAP Module Wire Colors for Corresponding Connector on Wiring Harness
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Connecting the SNAP PAC I/O Unit to a PC
The SNAP PAC I/O unit requires a connection to the PC running the PAC Project software. 
There are three ways to connect via Ethernet, as described below.

If you have a Wired+Wireless PAC R1, you can also connect to the PC using a wireless LAN. 
However, you must first use an Ethernet connection to assign an IP address to Ethernet 1.
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The Learning Center provides all the hardware to connect using Option 1; however, it may 
not be desirable to remove your PC from an existing network. Options 2 and 3 preserve 
your PC’s connection with a network, but require some networking expertise. It is 
recommended that you consult with your network administrator on which method to use.

Connecting Directly

The simplest way of connecting the I/O unit and a computer is using the Ethernet cable 
included with the Learning Center. 
1. Plug one end of the yellow Ethernet cable into the RJ-45 port on the SNAP PAC controller.
2. Plug the other end of the cable into an Ethernet port on the PC.

If an Ethernet port isn’t available because the computer is connected to a company network, 
consider one of the alternate methods of getting an available Ethernet port listed below:
• Disconnect the computer from the Ethernet network.

IMPORTANT: Check with your network administrator before disconnecting the computer from the 
network.

• Install and configure a second Ethernet network card in the PC.

NOTE: This can be a complex task if you are not familiar with setting up a Windows PC. You may want 
to get assistance with installing the network card or have the installation and configuration done by 
your system administrator.

Once you have an Ethernet port available on the PC, connect the SNAP PAC as described 
above.

Connecting through an Ethernet Network

The SNAP PAC I/O unit can be connected as a node on an existing Ethernet network. Once 
connected to the network, the SNAP PAC I/O unit can be accessed using the software 
included with the Learning Center.

When connecting the I/O unit to an existing Ethernet network, it is important to work 
closely with your network administrator, who must determine network topology and 
hardware requirements. The network administrator must understand that the I/O unit 
requires a fixed IP address. If a DHCP or BootP server is active on the network, the system 
administrator will need to provide you with a static IP address for use with the controller. 
You will learn how to assign an IP address in Lesson 1.

Connecting a Wired+Wireless Controller through a Wireless LAN

A Wired+Wireless SNAP-PAC-R1-W can be used on either an Ethernet network or in a 
wireless local area network (LAN) built with components that meet 802.11a, b, or g 
standards, depending on which works best for your environment. Before you can use the 
PAC wirelessly you must use PAC Manager on a wired network to configure wireless 
communication parameters. Note that the wireless LAN interface will work only if it is on a 
separate IP subnet, so the device can clearly determine where to direct communication. 
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Opto 22 Product Support
Opto 22 is here to help. When trying to solve a problem, a good rule of thumb is never 
spend more than an hour working on it before you call Opto 22. Your success is our success.

Phone: 800-TEK-OPTO (800-835-6786 
toll-free in the U.S. and Canada)
951-695-3080
Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

When calling for technical support, tell the Product Support Engineer you are using a SNAP 
PAC Learning Center. Also be prepared to provide:

• Your PC configuration (type of processor, speed, memory, and operating system)

• Any specific error messages seen

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.

mailto:support@opto22.com
http://www.opto22.com
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Chapter 1

1: PAC Manager—Communicating 
with the SNAP PAC

Skills
Network Communication

• Determining your PC’s I/O Address and Subnet Mask

• Using PAC Manager to establish initial communication with the SNAP PAC controller

• Assigning network IP addresses using PAC Manager

Scenario
In this lesson, you begin deploying the SNAP PAC I/O system in a fictional convenience store 
represented by the instruments on the Learning Center’s load panel. The scenario begins with a 
newly installed SNAP PAC R-series controller for monitoring and controlling various devices in a 
convenience store. Your SNAP PAC controller is already wired to your field devices (Learning Center 
Load Panel) and is connected to its power supply. Your first task is to establish network 
communications with the controller.
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Concepts

PAC Manager
PAC Manager simplifies the setup of your controller by providing basic management features. The 
diagram below outlines PAC Manager’s functions. In this lesson, you will use PAC Manager to 
establish communication with the controller and assign an IP address.
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IP Addressing
The SNAP PAC controller is shipped from the factory with a default IP address of 0.0.0.0. This address 
is not a valid network address. When you use your controller for the first time, the controller will 
send a BootP network broadcast requesting an IP address. PAC Manager “hears” the BootP 
broadcast, and from PAC Manager, you can assign an IP address. To assign an IP address, you need an 
IP address and subnet mask that are valid for your network.
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Activity

Preparing for the Lesson
You will need to know a valid IP address and subnet mask to assign to your controller. If your PC and 
controller are directly connected as described by Option 1 (above), this activity tells you how to 
determine a valid IP address and subnet mask. If you are using Options 2 and 3, it is best to consult 
your network administrator for an IP address and subnet mask.

Determining Your PC’s IP Address and Subnet Mask
Your SNAP PAC controller will need the same subnet mask that is assigned to your PC. The IP address 
will need to be compatible with the network your PC and controller are on. If you already have a 
valid IP address and subnet mask to assign to your controller (for example, you received these from 
your network administrator), you can skip the following steps and continue with “Using PAC 
Manager to Establish Communication with the Controller” on page 29.
1. Choose Start > All Programs > Command Prompt or choose Start > Run, type CMD in the Run 

dialog box, and click OK.
2. In the Command Prompt, type ipconfig and press Enter.

Your computer’s IP address and subnet mask are shown.

Choose a similar IP address for your I/O unit. For example, if your PC’s IP address is 10.0.4.2, 
assign an IP address such as 10.0.4.1 or 10.0.4.3 to your SNAP PAC controller.

3. Close the Command Prompt.
4. Click the close button in the top right-hand corner of the Command Prompt window.

Using PAC Manager to Establish Communication with the 
Controller
Once you’ve established what your controller’s IP address and subnet mask should be, you can 
establish communication between your PC and the controller. 
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1. From the Start menu, choose All Programs > Opto 22 > PAC Project [version number] > PAC 
Manager.

2. Select Tools > Assign IP address.
3. Turn on your SNAP PAC Learning Center.

The power switch is next to the power cord connection.

The controller is now broadcasting a BootP request for its network configuration.

Your SNAP PAC I/O unit is identified by its MAC address, also written on a label attached to the 
side of the controller’s housing. (The MAC addresses of Opto 22 devices begin with 00.a0.3d.) If 
no units are listed in the Units Sending BootP Request, turn your Learning Center off and then 
turn it on again.

4. Double click your controller’s MAC address.
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5. Type a suitable IP address (10.0.4.1 is used in this training guide). 
6. Type a suitable Subnet Mask (255.0.0.0 is used in this training guide).
7. Click OK.

This maps the MAC address to the IP address.

8. Click Assign.

9. Click Close.
10. Click No when asked to save the list of mappings.

The IP assignments and MAC addresses can be saved as a mappings file. Saving this 
information is helpful when you are configuring multiple controllers and I/O units. =
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Configuring a SNAP-PAC-R1-W for Wireless LAN 
Communication
This section applies to a SNAP-PAC-R1-W Wired+Wireless controller. A Wired+Wireless device sends 
its initial BootP request from Ethernet1, and the IP address you assign to it is for this primary 
interface. Make sure you have already assigned the IP address to Ethernet 1 before setting up 
wireless communications. See the instructions starting on page 29.

To communicate through the wireless LAN interface, you must assign it a separate IP address on a 
separate subnet and configure communication following the steps below.

IMPORTANT: The wireless LAN interface will work only if it is on a separate IP subnet, so the device can 
clearly determine where to direct communication. (The subnet masks don’t have to be different, but when 
you perform a logical AND on the IP address and subnet mask for each interface, the two results must be 
different.) For example, on a SNAP-PAC-S1-W you might use the following addresses and subnet masks: 

NOTE: If you need to configure or modify the settings for the network interface cards on your PC, you must 
be logged in with administrative rights.

1. If PAC Manager is not already open, choose StartProgramsOpto 22PAC Project Software
PAC Manager.

2. In the PAC Manager main window, click the Inspect button.

If this is the first time you have used the Inspect button, the Device Name field will be blank, as 
shown above. If you have used the Inspect button before, the last Device Name you used is 
shown, and the most recently used names and IP addresses are available in the drop-down list.

3. In the Device Name field, type the device’s name or IP address (or choose it from the 
drop-down list). 

4. Click Wireless LAN and choose Wireless LAN Configure from the popup menu.
5. In the WLAN Enable line, click the arrow next to Disabled and choose Enable. 
6. Leave WLAN Logging disabled and Rx Inactivity Timeout at the default of 300.
7. Under Network Block Configuration, enter the IP address and subnet mask for the wireless 

network. Remember that it must be on a separate network segment from the wired interfaces 
on the device. 

8. If necessary, enter the Primary and Secondary Gateway addresses. Leave the Primary and 
Secondary DNS fields blank.

9. Type in the name of the wireless network (SSID).
10. For Encryption Type, click the arrow next to None.
11. From the dropdown list, choose the security used on the wireless network. 

Additional fields appear.

12. Choose the Network Key Input Type, either Hexadecimal or ASCII (WEP is normally Hex; WPA 
and WPA2 are normally ASCII).

13. Enter the Network Key (the password for the network).

ENET1 ENET2 Wireless LAN

IP Address: 192.168.0.12 10.0.0.5 172.20.5.0

Subnet Mask: 255.255.255.0 255.255.255.0 255.255.192.0
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This field will show the password when you enter it; however, if you inspect the device later, the 
field will show only asterisks. 

14. When all fields are complete, click Apply. 
15. At the message asking whether you want to restart the device, click Yes. 

The configuration information is sent to the device and stored to flash memory, and the device 
is restarted. The WLAN LED turns orange to indicate that the interface is searching for or 
authenticating the wireless network. Once the network is found, the LED turns solid green.

16. To see connection status and signal strength, click the View Status button. (You can also see 
this screen by clicking Wireless LAN > Wireless LAN Status.)

Inspecting Points
PAC Manager has a variety of uses. Once communication is established, you can use PAC Manager to 
inspect points to ensure that your devices are connected to the modules. For example, you can use 
the Inspect mode to see a digital input point turn on and off or write to a digital output.
1. Choose Tools > Inspect.
2. In the Inspect I/O Unit dialog box, type the IP address you assigned to the SNAP PAC I/O unit 

and click Refresh.
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You can use the Inspect dialog box to examine all the features of the I/O unit. These features are 
listed as buttons on the left. You can also use these buttons to test reading and writing to 
points.

3. In the Inspect I/O unit dialog box, click Digital Point (Note: Make sure you click Digital Point and 
not Digital Bank.)

4. Click point 3.
5. On the Learning Center load panel, press the Photo Sensor switch down. This puts it into the 

On position.
6. In the Inspect dialog box, click Refresh.

The On state of the switch is shown under the value column.

Summary
PAC Manager provides essential tools for establishing network communication with SNAP PAC 
controllers and I/O units. As the SNAP PAC R combines control and I/O unit management, you used 
PAC Manager to assign an IP address and to inspect the connection between an I/O module and a 
toggle switch.

PAC Manager also can be used to configure the I/O in two ways:

• PAC Manager creates configuration files that can be stored on the PC, downloaded to I/O units, 
and imported into PAC Control.

• PAC Manager can edit the configuration that is currently active on the I/O unit.

I/O unit configuration can also be done using PAC Control. In this training guide, you will use PAC 
Control to configure the I/O unit.
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Chapter 2

2: PAC Control—Configuration 
and Programming

Skills
Building a Strategy

• Creating a new strategy

• Configuring a control engine

• Configuring I/O units and points

• Downloading a strategy

Debugging a Strategy

• Creating a New Strategy

• Configuring the Control Engine

• Configuring the I/O Unit

• Configuring I/O Points

• Making the Strategy Independent of Specific Controllers

• Observing Points in Debug Mode

• Writing to Outputs and Simulating Inputs in Debug Mode

Scenario 
Using PAC Manager, you assigned your SNAP PAC I/O unit an IP address so that your PC can “see” it 
on the network. Now you are ready to build your control strategy. A strategy is the software program 
you create in PAC Control. It includes all definitions and instructions necessary to control your 
process.

In this lesson, you will configure the SNAP PAC I/O unit so it can actuate outputs and read sensors 
connected to your I/O modules.
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Concepts

I/O Configuration
In the previous lesson, you used PAC Manager to establish network communication with the SNAP 
PAC I/O unit. The next step is to set up the basics of your strategy in PAC Control, so you can assign a 
control engine and configure an I/O unit. Configuration involves defining the I/O attached to the 
controller and indicating which features to use, such as scaling for analog points and counters for 
digital points. Configuration also includes assigning names to your points to identify them.
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PAC Manager and PAC Control
You could use PAC Manager to configure the I/O unit, modules, and points. In fact, PAC Manager 
provides specialized configuration options for serial modules, protocols such as PPP, Modbus/TCP, 
SMTP, and SNMP messaging.

For most necessary configurations, however, PAC Control is the easiest and most convenient option 
for configuration. If you want to learn more about configuring I/O units in PAC Manager, see the PAC 
Manager User’s Guide, form #1440. 

PAC Control
In this lesson, you will explore PAC Control’s application development environment by:

• Creating a new PAC Control strategy.

• Configuring the SNAP PAC R controller as the Control Engine.

• Downloading your strategy to the controller.

• Configuring I/O points.

• Monitoring your points in Debug mode.

You will add control logic in the lessons that follow. The diagram below summarizes the features of 
PAC Control that you will use in this lesson. 
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Activity

Creating a New Strategy
1. From the Start menu, select All Programs > Opto22 > PAC Project [version number] > PAC 

Control Basic.
2. Select File > New Strategy.
3. In the Create New Strategy dialog box, navigate to the SNAP PAC Learning Center directory. 

For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC Learning Center

4. Open the SNAP PAC Learning Center folder and type Convenience Store in the File 
name field as the name of the new strategy. 
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5. Click Open.

This action creates a new strategy, which initially consists of a Strategy Tree and a Powerup 
chart. The Powerup chart is the starting point for control logic, which you’ll add in later lessons. 

The Strategy Tree presents all the information in your strategy in a simple folder structure. At a 
glance, you can see the number and types of all I/O points and variables. All charts, configured 
hardware, and variables are listed for easy reference. Just expand and contract the folders by 

Strategy Tree

Powerup chart—
automatically created 
with a new strategy
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clicking the plus ( ) and minus ( ) symbols to view components. Double-clicking any folder 
displays dialog boxes for configuring or debugging.

Configuring the Control Engine
First, you will configure the Control Engine, which defines the communication parameters between 
the host PC and the SNAP PAC controller.

I. Add a Control Engine Configuration

1. In the Strategy Tree, double-click Control Engines to open the Configure Control Engines dialog 
box.

Communication 
parameters between the 
PC and the controller

Variables: 
The variables you create 
when building your 
strategy reside in these 
folders. When you create 
a variable, you provide 
the variable type.  The 
sorting is automatic.

Subroutines:
Reusable PAC Control code

Flow charts: 
The Powerup Chart is 
provided with every strategy 
and is used to start other 
charts.

I/O configuration

You can double-click any of these 
folders to access these features. 
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2. Click Add to open the Select Control Engine dialog box, then click Add again.

NOTE: If other controllers have been configured on this computer, they are listed in the Select Control 
Engine dialog box.

3. In the Select Control Engine dialog box, click Add to open the Control Engine Configuration 
dialog box.
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4. Type SNAP PAC as the control engine’s name.

A descriptive name helps to make debugging and strategy maintenance easier.

5. Select Standard as the System Type.
6. Type the IP address for your SNAP PAC I/O unit, and then click OK.

II. Select the Active Control Engine

1. In the Select Control Engine dialog box, select SNAP PAC from the list and then click OK.

When only one control engine is configured for use with a strategy, that control engine is 
automatically designated the active control engine. The active control engine is the one to 
which the strategy will be downloaded. You can configure several control engines, but only 
one is active at any time.

If more than one control engine appears in the Configure Control Engines window and the 
control engine you wish to use does not appear in the Active Engine field, select the control 
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engine from the list and click the Set Active button. The selected control engine name is then 
shown in the Active Engine field.

Notice that control engines can be added, deleted, and modified from this window.

2. Click OK to close the Configure Control Engines window.
3. Click the plus sign ( ) to the left of Control Engine in the Strategy Tree to expand the folder.

Notice that your control engine is now listed in the Strategy Tree.

You’ve just used PAC Control in Configure mode. To test your communications with the control 
engine, you will use PAC Control’s Debug mode.

Control engine
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III. Test Control Engine Communications
To test communications, you can download your strategy to the control engine. At this point, your 
strategy is essentially empty, but this step will ensure that control engine communications are 
correct.
1. Select Debug from the Mode menu, or click the Debug icon in the toolbar.

This action saves, compiles, and downloads the strategy. The Save Strategy dialog box appears.

NOTE: This dialog box also appears if power has been turned off and on since the last download

2. Click Yes.

If this is the first strategy to be downloaded since power has been cycled to the control engine, 
a PAC Control window will open with a “Powerup Clear Expected returned from control engine” 
message.

About Configure, Debug, and Online Modes:

A PAC Control strategy is written and edited in Configure mode. When you switch to 
Debug mode, PAC Control saves, compiles, and downloads the strategy to the control 
engine. In Debug mode, you can examine and modify I/O point states and variable values. 
You also can monitor the step-by-step execution of your PAC Control strategy.

TIP: If you can’t locate a feature 
or dialog box, check that you 
are in the correct mode. 
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3. Acknowledge the message by clicking OK.

Occasionally the control engine memory may be cleared. This can occur if the firmware file was 
just downloaded, if the memory was cleared in Debug mode, or if the power was turned off 
and the battery was dead.

4. Click Yes.

If the strategy running on the control engine is different from the strategy being downloaded, a 
Download Warning window opens.

5. Click Yes.

The Strategy Download dialog box appears.

6. Click the Run button ( ) to start the strategy.
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7. Look at the lower right-hand corner of the PAC Control window. If there are no errors, you are 
communicating successfully 

IV. Using PAC Control Menu and Toolbars in Debug Mode
When you switch to Debug mode, the Run, Stop, and Pause buttons, and the debugging tools 
become available.

V. View Control Engine Status
To view the control engine status in Debug mode, double-click your control engine, SNAP PAC, in 
the Strategy Tree.

The selected button (Debug) 
indicates the current mode.

Run, Stop, and 
Pause buttons

Debugging tools
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The Inspecting dialog box describes the versions of the loader and firmware on the controller. It 
also provides information about the controller’s memory: 

• A SNAP PAC R controller has 8 MB of RAM on the control side, 1 MB of which is 
battery-backed.

• Volatile RAM shows the amount of total RAM available for use. 

• Persistent RAM shows the amount available in battery-backed RAM, where persistent 
variables, variables initialized on download, the autorun flag, and the strategy archive are 
stored.

• Loop Time is the time required to gather the inspection data from the control engine (time 
taken for a single transaction). For more information on the Inspecting dialog box, see the 
PAC Control User’s Guide, Opto 22 form 1700.
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VI. Returning to Configure Mode
At this point the strategy is still running. You can leave it running as you switch back to Configure 
mode.
1. Close the Inspecting dialog box.
2. Click the Configure mode button on the toolbar or choose 

Mode > Configure.

Configuring the I/O Unit
1. Double-click I/O Units, or right-click I/O Units and choose Configure.
2. Click the Add button or double-click in the list box to open the Add I/O Unit dialog box.

Autorun
Autorun determines whether the strategy starts automatically 
when downloaded or when the control engine is restarted.
Users of older Opto 22 controllers will notice that the autorun 
flag in the SNAP PAC controller is a software setting, instead of 
a hardware jumper setting.
In PAC Control, the autorun flag can be set in two places in the 
strategy download options: 
• In the Inspecting Controllers dialog box.
• In the Download Options found under File > Strategy 

Options, Download tab.

Archive
The archive feature says “Not 
Available” because an archive 
of the strategy has not been 
downloaded to the controller. 
In Configure mode, you can 
set the strategy options to 
also archive the strategy to 
the controller upon 
download. See File > Strategy 
Options, Archive tab.
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3. Type SNAP PAC io in the Name field. Notice that spaces are converted to underscores.
4. Select SNAP-PAC-R1 as the Type.
5. Type the IP address you’ve designated for the I/O unit. Because the SNAP-PAC-R1 is a combined 

controller and I/O unit processor, you use the same IP address for the I/O unit as you used for 
the control engine.

6. Select Fahrenheit.

There is no need to change the default 
Port or Watchdog settings.

7. Click OK to close the Add I/O Unit dialog 
box.

Leave the Configure I/O Units dialog box open 
for the next steps.

About Watchdog
The Watchdog option is used to monitor activity 
on the port. When a watchdog is enabled and no 
communication is received for the specified time 
interval, the unit assumes a watchdog state, 
which sets designated digital and analog output 
points to pre-determined values. In this strategy 
we are not using watchdogs.
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Configuring I/O Points
Configuration involves identifying each module attached to the I/O unit and specifying which 
points are in use. (Configuration prepares the I/O unit for use by PAC Control flowcharts, which will 
be explained in Lesson 3.) I/O points can be configured on-the-fly (as you need them when creating 
flowcharts) or all at once (before they are used). In this exercise, you will configure the I/O points 
that you will need using the all-at-once method.

I. Define a Digital Input Module

1. On the Configure I/O Units dialog box, click the I/O Points button, and then select module [00].

2. Click the Add button to configure this module.
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3. Select Digital Input as the Type.
4. Select SNAP-IDC5D: 2.5 - 28 VDC as the Module.
5. Click OK to close the Add Module dialog box.

The module is now defined in the Configure I/O Points dialog box.

II. Configure Digital Input Points

1. Click the plus symbol ( ) next to the digital input module you just added.
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Now you can see the available points. As this is the first module on the rack, its points are 
numbered 00, 01, 02 and 03.

2. Double-click Point 0, or select Point 0 and click the Add button.

3. Type Emergency for the point name, and then click OK to close the Add Digital Point dialog 
box.

4. Double-click points 1, 2, and 3 and assign them the following names:

NOTE: Type the point names exactly as shown here.

When complete, your Configure I/O Points dialog box will appear as follows:

Point Name

1 POS

2 Freezer_Door

3 Photo_Sensor
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III. Configure a Digital Output Module

1. Double-click Module 01 to open the Add Module dialog box.

2. Select Digital Output, and then select the SNAP-ODC5SRC: 5 - 60 VDC module.
3. Click OK to close the Add Module dialog box.

IV. Configure Digital Output Points

Configure your Digital Output module and points with the information shown below, as described 
in the following instructions.
1. Expand the points for Module 01 (click ).
2. Double-click Point 0.
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3. Type Alarm.
4. Click OK.
5. Assign the following names to points 1, 2, and 3:

NOTE: Type the point names exactly as shown here.

When you are finished, your Configure I/O Points dialog box should appear as follows:

V. Configure an Analog Module

1. Collapse the points from modules 00 and 01 by clicking the minus symbols ( ) next to them.
2. Double-click Module 02 (or select Module 02 and click Add).

Point Name

1 Freezer_Door_Status

2 Inside_Light

3 Outside_Light
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3. Select Analog Output, and then select the SNAP-AOV-27 module.
4. Click OK to close the Add Module dialog box.

VI. Configure and Scale an Analog Point

1. Expand the points below Module 02.
2. Double-click Point 0 to open the Add Analog dialog box
3. Name the point Fuel_Display, and next to Module, select SNAP-AOV-27: -10 - +10 VDC 

(Scalable).
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4. Type the following values in the Scaling 
group:

– Units: Gallons

– Lower – Actual: 0

– Lower – Scaled: 0

– Upper – Actual: 10

– Upper – Scaled: 10000 (NOTE: Do 
not use a comma separator, and 
make sure to type 10000 instead of 
1000.)

5. Click OK to close the Add Analog Point 
dialog box.
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VDC

10

5

0

–5

–10

Gallons

10,000

5,000

0

–5,000

–10,000

Although the module can output -10 VDC, 
the meter is at minimum when the output 

is 0 VDC.

10 VDC signal to meter 
on load panel

0 VDC signal to meter on load panel

equals

equals

Scaling the meter involves correlating 
two points from the module's natural 
scale (VDC) to two points on an arbitrary 
scale, such as gallons.

10 2 3 4 5 6 7 8 9 10

Scaling the meter

Module's
natural scale Your scale

About Scaling

Scaling your meter allows you to correlate the natural scale of the module, which is in voltage, 
to a more understandable value, such as gallons.

VDC Gallons

equals

0

5

0

-5

-10

10

equals

10,000

5,000

-5,000

-10,000

Scaling the Meter: Inserting the Correct Values
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VII. Configure Module 03

1. Double-click module 03, or select module 03 and click Add.
2. Select Analog Input, and then select the SNAP-AICTD module.

3. Click OK to close the Add Module dialog box.

VIII. Configure Module 03, Point 0

1. Expand the points below module 03. 
2. Double-click point 0, name the point Store_Temperature, and then click OK to close the Add 

Analog Point dialog box.
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IX. Configure Module 04

1. Double-click Module 04 (or select Module 04 and click Add).
2. Select Analog Input, select the SNAP-AIV module and then click OK to close the Add Module 

dialog box.
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X. Configure Module 04, Point 0

1. Expand the points below module 04 and double-click Point 0 to open the Add Analog Point 
dialog box.

2. Name the point type Fuel_Level.
3. Next to Module select SNAP-AIV: -10 - + 10 VDC (Scalable).

4. Type the following values in the Scaling group:

– Units: Gallons

– Lower – Actual: 0

– Lower – Scaled: 0

– Upper – Actual: 5

– Upper – Scaled: 10000
5. Click OK to close the Add Analog Point dialog box.
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The Configure I/O Points dialog box now shows this configuration information:

VDC Gallon

equals

0

5

0

-5

-10

10

equals

20,000

10,000

-10,000

-20,000

VDC

10

5

0

–5

–10

Gallons

20,000

10,000

0

–10,000

–20,000

Min Max

Input signal from 
potentiomer ranges 
from: 0 VDC (minimum) 
to:  5 VDC (maximum)

(The potentiometer doesn’t 
use the full scale of the 
input module.)

5 VDC signal
to module

0 VDC signal to module

equals

equals

Scaling this potentiometer involves correlating two points from the module's 
actual scale (VDC) to two points on an arbitrary scale, in this case, gallons.

Scaling the Potentiometer

Module's actual scale,
-10 to 10 VDC... ...correlates to two points

on your scale

Module's actual scale is 
determined by the type of 
signal it reads or transmits, 
such as 0–20 mA, 0–10 VDC, 
4–20 mA.

Scaling the Potentiometer
The range of the potentiometer is different from the meter’s range, but since we need the two to 
correlate, we used different settings so both devices will use the same range.

Scaling the Potentiometer: Inserting the Correct Values
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6. Close the Configure I/O Points dialog box.
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Making the Strategy Independent of Specific Controllers
If you have more than one SNAP Ethernet-based I/O unit, you could build a system in which the 
SNAP PAC I/O unit controls all the units with one strategy. This diagram shows a hypothetical SNAP 
PAC I/O unit controlling other units. Notice that the I/O unit running the control strategy has local 
I/O, meaning the I/O is on the same unit as the control engine.

As you build your strategy, you will add commands that read from and write to points. The strategy 
will find these points using the IP address defined in the I/O Unit properties. By using the controller’s 
IP address within the I/O unit configuration (e.g., 10.0.4.1), you hard-coded all interaction with the 
I/O at the named IP address. Next, you’ll see how to configure your I/O unit so that it is always local 
regardless of which IP address you may assign to the hardware.
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1. Expand I/O Units and then double-click SNAP_PAC_io in the Strategy Tree to open the Edit I/O 
Unit dialog box.

2. Select Local (loopback) to automatically set 127.0.0.1 for the IP Address.
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3. Click OK to close the Edit I/O Unit dialog box.
4. Choose Mode > Debug or click the Debug button on the toolbar.
5. Acknowledge any download messages.
6. Choose Debug > Run.

Observing Points in Debug Mode
Now that your I/O points are configured, you can observe the status of the points while in PAC 
Control’s Debug mode.
1. Double-click the Points folder to open the View I/O Unit dialog box.

2. While viewing the I/O unit, turn on and off the switches on your Learning Center.

You will notice the states of these points in the XVAL column.

You can use this dialog box while your strategy is running 
to monitor points and to force input or output values.
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3. Turn your Fuel Level potentiometer and notice its value in the XVAL column.

NOTE: You may need to scroll down the list to see the Fuel_Level point.

Writing to Outputs and Simulating Inputs in Debug Mode
PAC Control has two representations of a point’s state or value. One representation is the true state 
being reported by the I/O module, which is called the XVAL (X for external). The IVAL (I for internal) 
represents the value within PAC Control of any point that is referenced in the strategy. (Points not 
used in the strategy will not have updated IVALs.) The internal and external values are linked, 
meaning their values or states are identical. However, when debugging your strategy, you may wish 
to disable the link between the IVAL and XVAL to test how your PAC Control strategy would react to 
hypothetical states and values. For example, to test your strategy with an extreme condition, you 
may need to disable an input to simulate an out-of-tolerance value.
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I. Write to an Output Point

1. In the View I/O Unit dialog box, double-click Point 1, Freezer_Door_Status.
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2. Click the Maximize button ( ).

You can write to an output point by changing the 
XVAL.

3. Click the up-down arrows in the XVAL field to 
change the Off state to On.

4. Click Apply.

Notice that your Freezer Door Status LED is on.

5. Repeat to turn off the light.
6. Click the Close button.

II. Examine Other Points
You can open other points from the View I/O Unit dialog box. 

NOTE: The first point on the module in position 1 controls an audible alarm, which you may not wish to 
turn on until you’re confident that you can promptly turn it off.

1. Double-click any of the points in the View I/O Unit dialog box.
2. Expand their view dialog boxes.
3. Turn on and off the IVALs and XVALs and click Apply.

NOTE: If you want to write to an output point, you have to use the XVAL. If you try to change the XVAL of 
an input point, it will be overwritten by the true setting of the field device. 

III. Return to Configure Mode.

1. When finished examining points, close all dialog boxes.
2. You may leave your strategy running.
3. Choose menu command Mode > Configure.

You will continue using PAC Control in the next lesson.

Leave your strategy and PAC Control open if you plan to continue to Lesson 3 now; otherwise, save 
and close your strategy and close PAC Control.
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Chapter 3
Chapter 3

3: PAC Control—Flowcharts

Skills
PAC Control

• Creating a Flowchart

• Choosing Flowchart Colors and Text

• Closing Your Chart

• Adding a Command to the Powerup Chart

• Using the Flowchart Drawing Tools

• Adding an Instruction

• Completing an Instruction

• Archiving Your Strategy

• Setting Workspace Options

Scenario
In the previous lesson, you created a strategy using PAC Control. The strategy includes the control 
engine you defined and the I/O you configured. The I/O configuration allows you to actuate any 
devices and read any sensors connected to your I/O modules. This level of control allows you to test 
and modify your system from a remote location, but it lacks the control logic needed to 
automatically turn on and off lights, trigger alarms, and record activities and transactions. To have 
these capabilities, you need programming logic, which you create using flowcharts in PAC Control.

In this scenario, your PAC Control strategy controls one SNAP PAC I/O unit; however, this isn’t the 
only possible use of these systems. For example, you may have several SNAP PAC I/O units, each 
controlling a different process and therefore running different strategies. Or you may have two or 
more SNAP PAC R systems controlling identical processes in different areas and running the same 
strategy. You can also deploy one SNAP PAC I/O unit with a strategy and other SNAP Ethernet-based 
I/O units with no strategy that are controlled by the master I/O unit.

You are beginning the major application development phase of your project. Over the next few 
lessons you will add programming logic and variables to your strategy while frequently testing your 
changes.
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Concepts

Strategy (Review)
The software program you created using PAC Control is called a strategy. In the previous lesson you 
saw that a typical PAC Control strategy consists of the following:

• Control Engine—This defines communication between the PC and the SNAP PAC I/O unit. It is 
required to download and run strategies in Debug mode. Your strategy contains the control 
engine you created in Lesson 2.

• Flowcharts—These contain the programming logic of your strategy. All strategies include a 
Powerup chart used to start the charts you create.

• Variables—These contain information as integers, floating points, strings, etc.

• I/O Configuration—This information defines the points that can be controlled. You recently 
assigned your I/O unit the loopback address of 127.0.0.1, ensuring that this strategy uses the 
local I/O unit on any SNAP PAC I/O unit it resides on.

Flowcharts
Since most control applications are complex, a strategy typically consists of several process 
flowcharts, or charts, that all work together. Each chart controls one aspect of the strategy—one 
piece of the automated process. Together, all the charts constitute the strategy. The total number of 
charts in a strategy is limited only by the amount of memory available in the control engine. 

A chart can be running, suspended, or stopped. A running chart is actively performing its assigned 
task. A suspended chart is temporarily paused. A stopped chart is inactive. Every chart in a PAC 
Control strategy can change the status of any other chart in the strategy, yet every chart is 
independent. Any combination of charts can be running simultaneously, up to the maximum of 16 
with SNAP PAC R (and 32 with the SNAP PAC S controller).

Every strategy contains a Powerup chart. The Powerup chart automatically starts when the strategy 
begins running, so it can be used to start other charts.
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Blocks
Each chart is made up of blocks connected by arrows, which show how the process flows. Action 
blocks are rectangular in shape and indicate action within the process. Condition blocks are 
diamond-shaped and indicate a decision point. OptoScript blocks are hexagonal and contain 
OptoScript code, an optional method of programming. Continue blocks are oval and simply point to 
another block in the chart to continue the process. Action, Condition, OptoScript, and Continue 
blocks are shown in the chart below:
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Multitasking
The control engine can run several charts seemingly at once, each performing a different task, 
through a technique called multitasking (also called multi-charting). The SNAP PAC R-series control 
engine runs up to 16 tasks (charts) simultaneously. (The SNAP PAC S-series control engine runs up to 
32 charts simultaneously.)

The host task is an invisible chart used to communicate to a PC, which may be running PAC Control 
in Debug mode or PAC Display. Each chart in a running or suspended state counts toward the total 
that can run simultaneously. Charts that are stopped do not. When the Powerup chart is running, it 
also counts.

The actual order and timing for running tasks is not deterministic—that is, it is not always the same, 
but depends on priorities at any given time. For example, communication may sometimes take a 
higher priority than a running chart. 

Variables
A variable is a holding place that represents a piece of information in a strategy, such as the 
parameters for communication, temperature reported by a thermocouple, the name of a chart, or a 
group of words and numbers to be sent to a display. The information a variable represents is called 
the value of the variable. As a strategy runs, the variable’s name remains the same, but its value may 
change. For example, the value of a variable named Fuel_Level may change several times while its 
strategy is running, but its name remains Fuel_Level.

Block 0 is created for you when you create a new 
chart. A chart's programming logic always begins at 
Block 0, regardless of where it is within your chart. 
Block 0 can be renamed, but it can't be deleted.

These blocks contain Action or Condition 
commands. When editing these blocks, you can 
select action commands or condition commands, 
depending on which type of block you are editing. 
If you insert multiple commands in an action block, 
the commands are executed in order. Multiple 
commands in condition blocks are evaluated 
collectively: for example, condition 1 and condition 
2; condition 1 or condition 2.

You can use the script-based equivalents of action 
and condition commands in script blocks, as well as a 
variety of logical structures.

You can use Continue blocks as an alternative to 
drawing connection lines within a chart. As with any 
Go To command, use Continue blocks judiciously.
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A variable stores one of six types of data: floating point, integer, timer, string, pointer, or 
communication handle. When you create the variable, you designate the type of data it contains.

• A floating point (or float) is a numeric value that contains a decimal point, such as 3.14159, 
1.0, or 1234.2. A good example of a float variable is one that stores readings from an analog 
input, such as a thermocouple.

• An integer is a whole number with no fractional part. Examples of integer values are -1, 0, 1, 
999, or -456. The state of a switch, for example, could be stored in an integer variable as 1 (on) 
or 0 (off ).

• A timer stores elapsed time in units of seconds with resolution in milliseconds. Up timers 
count up from zero, and down timers start from a value you set and count down to zero. For 
example, you could set a down timer to make sure a value is updated at precise intervals. 

• A string stores text and any combination of ASCII characters, including control codes and 
extended characters. For instance, a string variable might be used to send information to a 
display for an operator to see. A string variable can contain numeric characters, but they no 
longer act as numbers. To use them in calculations, you must convert them into floating point 
or integer numbers. And a numeric value to be displayed on a screen must be converted into a 
string first. 

• A pointer does not store the value of a variable; instead, it stores the memory address of a 
variable or some other PAC Control item, such as a chart or an I/O point. 

• Communication handles store parameters needed for communication with other devices.

You can use variables that are individual pieces of information, and you can also use table variables, 
which are groups of related information in the form of a table.

Activity

Creating a Flowchart
When you open a new PAC Control strategy, one chart already exists in the strategy: the Powerup 
chart. You create other charts as needed.
1. Select New from the Chart menu.
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2. Type Lighting Control in the Name field. The space will automatically be replaced by an 
underscore.

3. Press the Tab key on the keyboard to advance to the next field.
4. Type an explanation of the chart’s function in the Description field.
5. Click OK.

An action block called Block 0 is the only block in the new chart. Block 0 is always the first block 
executed in any chart. Block 0 can be renamed, but it cannot be deleted.

Choosing Flowchart Colors and Text
Many features of charts are available in context-sensitive menus.

I. Change Flowchart Properties

1. Place the cursor in the Lighting_Control window.
2. Click the right mouse button.
3. Select Flowchart Properties from the shortcut menu.
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4. Click the Display Block IDs box to uncheck this box and turn off the ID number display.

5. Click the Color block in the Condition Block Parameters section.
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6. Click one of the color blocks displayed under Basic Colors to select a new default color of a 
condition block. (You can keep the existing color, if you prefer.)

7. Click OK to close the Color dialog box.

II. Change the Default Text of Condition Blocks

1. Click the Font box in the Condition Block Parameters section.

2. Enter 9 in the Size field to change the text font for condition blocks. Feel free to change the font 
or color as well.

3. Click OK to close the Font dialog box.

Experiment and change the colors and fonts of the Action and Continue Blocks. 



3: PAC CONTROL—FLOWCHARTS

SNAP PAC Learning Center User’s Guide 7777

You can also change the color of the connection lines by clicking on the narrow rectangular block 
under Connection, True Connection and False Connection. Some PAC Control users like to make the 
true connection line green, and the false connection line red.

III. Apply Your Changes
The Also Apply To options expand the scope of the chart properties. 
Selecting PAC Control applies the changes throughout all new strategies. 
Selecting Strategy applies the changes throughout all new charts in the 
current strategy. The All Charts option applies the changes to all new 
charts and new graphic elements in the current strategy. 
1. Click the PAC Control, Strategy, and All Charts options in the Also 

Apply To field to apply these defaults to all new charts in this 
strategy and future strategies. (Changes take effect as new charts or 
new chart objects are created.)

2. Click OK.

Because it was created before you changed the default properties, Block 0 still has the old 
properties. To give Block 0 the new properties, select the block, right-click, and select Properties > 
Copy from Default.

Object properties can be changed individually to easily customize the look of your flowchart. The 
properties for individual objects can be changed by selecting the object, right-clicking, and 
choosing the property to be changed from the pop-up menu.

IV. Reset the Changes

If you do not wish to use the new settings, do the following:
1. Open the Configure Chart Properties dialog box.
2. Choose Reset All. 
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3. Click Apply.

Closing Your Chart
You will close your Lighting_Control chart for now.
1. Close the Lighting_Control chart by clicking the close box ( ) in the upper-right corner of the 

chart’s window.

When you close a chart window where you have made changes, you are prompted to save the 
chart.

2. Click Yes to save changes to your chart.

Adding a Command to the Powerup Chart
You’ve created the chart Lighting_Control. For this chart to run, it must be started by a command in 
another flowchart. The Powerup chart is started automatically, so this is the best location for 
commands that start all charts you want running when the strategy starts.

To create this capability you will do the following:

• Add an Action block to the Powerup chart. 

Close Box on Maximized Charts

If you have maximized your 
chart, you will find the close 
box for the chart in the top 
right corner of the PAC 
Control application window.
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• Add a Start Chart command to the action block.

• Create a variable to contain the command to start the Lighting_Control chart.
1. In the Strategy Tree, expand the charts folder.
2. Double-click Powerup in the Strategy Tree.

3. Resize the chart if desired. You can maximize the window by clicking the maximize button 
( )

4. Use the scroll bars at the bottom and left of the window to center Block 0 in the Powerup 
window.
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5. Assign new properties to the Powerup chart

Because the Powerup chart was created before you changed the default chart properties, Block 
0 still has the old properties.

To give Block 0 the new properties, select the block, right-click, and select Properties > Copy 
from Default.

Using the Flowchart Drawing Tools
There are six drawing tools in PAC Control. The drawing tools are used to create flowcharts and 
select flowchart objects.

If you can’t see your chart objects:
If you scroll too far, you can lose sight of your flowchart 
objects. Use Center on Block to locate any chart block: 1. Maximize your chart.

2. Right-click in a chart window.
3. Select Center on Block.
4. In the Center on Block dialog box, 
select a block, for example, Block 0.
5. Click OK.
(The example shown here is based 
on a completed flowchart you create 
in this lesson.)
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I. Draw an Action Block

1. Select the Action Block Tool from the tool bar.
2. Position the cursor below Block 0 in the Powerup chart.
3. Click the left mouse button.

Chart Tools:

Hand Tool: Use to move the chart within the workspace

Selection Tool: Use to manipulate flowchart objects.

Chart Objects: Once selected, each one of these tools 
places its corresponding object until you choose the 
Select tool or a different chart object tool.

Placing Blocks:
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Block 1 has been created in your flowchart. Block 1 is the default name of this action block. Every 
block created in PAC Control is given a default name in numerical order. Once a name has been 
issued, it is not reissued. If you delete Block 1 and draw a new block, the name of the new block will 
be Block 2. The default names of the blocks are temporary. You should always change the name of a 
block to describe the function of the block in the flowchart. 

II. Rename an Action Block

1. Click the Select tool ( ).
2. Click Block 1 to select it.
3. While Block 1 is selected, click the right mouse button. A pop-up menu of available options for 

the selected object opens.
4. Select Name from the list.
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5. Type Start Charts as the name of the block.
6. Click OK.

III. Connect Start Charts Block to Flow

Now, you will draw a line defining the flow of logic in the chart.
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1. Select the Connect tool.
2. Click Block 0.
3. Click Start Charts.
4. Click the Select tool to release the Connect tool. (You can also press the Escape key, or 

right-click on a blank area in the flowchart window to release the Connect tool.)

Connect tool:
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Do your connection lines look like this?
If you are having difficulty using the connection tool, the diagrams below 
provide some advice on how to draw and revise connection lines.

Controlling Your Connection Lines:
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Adding an Instruction
The blocks in charts are just shells used to contain instructions and scripts. You’ve just placed a new 
action block and connected to the flowline, but this block must include some instructions.
1. Double-click the Start Charts block to open the instruction window.

You can also open the instruction window by selecting the block, clicking the right mouse button, 
and selecting Detail from the pop-up menu

NOTE: Double-clicking a block opens the Instructions window. Other block properties, such as name and 
color, are changed by right-clicking the block and selecting from the context-sensitive menu.

2. Click Add to enter a new instruction.
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3. Locate the Start Chart instruction.

There are several ways you can select an instruction. Three methods are listed below. Select 
one of the methods to enter the Start Chart instruction into the Start Charts block.

One: Type the beginning letters of the instruction.

If you know the instruction that you want, type the first few letters of the instruction until the 
instruction appears in the field. For the instruction Start Chart, you can type St and the Start 
Chart instruction is selected in the field.

Two: Use the drop-down button.

– You can click the drop-down button at the end of the Instruction field and scroll through 
the list of all available instructions. To quickly jump to different areas of the list, type a few 
letters in the Instruction field.

– Once you are in the drop-down field, you can use the up and down arrow keys on your 
keyboard to move through the list until you locate the Start Chart command.

Three: Use the Select button.

– If you do not know the name of the instruction you need, click the Select button.

– From the Select Instruction window, select the group that is related to the type of 
instruction desired. To find the Start Chart instruction, highlight Chart in the Groups list. 
Start Chart can now be selected from the list of instructions.
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Completing an Instruction
Each instruction requires additional information to be complete. When you choose the Start Chart 
instruction, you must also provide the following:

• Name of chart to start. Lighting_Control already appears because it is first in an alphabetical list 
of available charts (the only other chart is Powerup).

• Variable to contain status of loading the chart. 

When a Start Chart instruction is 
executed, PAC Control returns a 
status of 0 if the requested chart was 
successfully started. If the chart was 
already running or unable to start 
because 16 tasks were already 
running, PAC Control returns a -5 
status. The status can be used to 
verify that a chart was successfully 
started before the flowchart strategy 
continues. To store this information, 
you’ll need to create a variable.

NOTE: Status and error codes are 
described for each command in the 
command help, available from the 
Command Help button.

I. Complete the Instruction

1. In the Comment field, enter the 
following description:

Defining variables:
When a feature such as an instruction requires a 
variable, you can select an existing variable or define a 
new one. If you define a new variable, the Add 
Instruction dialog box links to Variable Definition 
dialog boxes. This is called creating a variable 
on-the-fly.

As an alternative, you can always open the Variable 
Definition features from the Variables folders in the 
Strategy Tree.

It is always a good idea to select the type of variable 
that is appropriate for the type of data that will be 
stored. PAC Control can store an integer in a floating 
point variable and let you use it as an integer. However, 
this requires an unnecessary data conversion. The 
unnecessary data conversion is automatically 
performed, but it does require processor time.
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Status: 0, success; -5, failure

The Start Chart command name is self-describing, so in this case you have entered the status 
codes returned for this command.

2. Select Lighting_Control from the drop-down list under Name.
3. For the variable type (Put Status In), select Integer 32 Variable.

When the chart is started, a status code of 0 or -5 is put in the variable you determine. Since 0 
and -5 are integers, you use an integer 32 variable.

4. In the Put Status in–Name field, type Status_Trashcan to create this variable using the 
on-the-fly method of variable configuration. 

The spaces between words you type are automatically replaced by underscores. This new 
variable will store the value of the returned status.

5. Click the Tab key on the keyboard.

Since Status_Trashcan is an undefined variable, you are prompted to add the variable to your 
strategy.

6. Click Yes to add the new variable.

The Add Variable dialog box is displayed.
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7. Type a description of the variable’s function:

Reports startup of chart

8. Click OK to close the Add Variable dialog box.
9. Click OK to close the Add Instruction dialog box.

The completed instruction can be viewed in the Instructions window.

10. Click Close to complete the entry of this instruction.

Additional instructions can be created, which you will do later when you start another chart. 
When you have multiple instructions within a block, instructions are executed in listed order. 
The order can be changed by using Copy and Paste to move the commands. 
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II. Save the Strategy

1. Select Save Strategy from the File menu.

Modified charts that have not been saved are listed in the Save Strategy window.

2. Click OK to save the highlighted charts.

In general, it is a good idea to save your strategy every 10 minutes. When a strategy is downloaded 
to a control engine, it is automatically saved. Therefore, if you are frequently downloading and 
testing your strategy, it is not necessary to continuously save your strategy.

Archiving Your Strategy
It is a good idea to save several copies of your strategy as it is developed. This practice makes it easy 
to revert to previous versions of your strategy.

Archive Strategy creates a point-in-time snapshot of your strategy within a ZIP file. Archiving your 
strategy has three main advantages:

• You can store multiple archives in the same directory.

• Archiving stores all related files as one ZIP file.

• The archive file has a time and date stamp in the file name.
1. Select File > Archive Strategy.
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The strategy is archived. The message asks if you wish to see the location of the archive file.

2. Click No.

Setting Workspace Options
You can configure PAC Control to automatically open the last strategy that was opened.
1. Select Configure > Options.

2. Check the box Load last strategy at startup.
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3. Click OK. 

Leave your strategy and PAC Control open if you plan to continue to Lesson 4 now; otherwise, 
save and close your strategy and close PAC Control.
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Chapter 4
Chapter 4

4: PAC Control—Digital Control

Skills
Configuring a Strategy

• Building the Chart

• Adding Control for the Freezer_Door and the Emergency Switch

• Modifying the Lighting_Control Chart

Debugging

• Configuring Debug Mode

• Downloading and Running the Strategy

• Using Auto Stepping

• Using Step Buttons

• Debugging the Changes

• Forcing Outputs and Inputs in Debug Mode

Scenario
In the previous lesson, you started building your programming logic by creating a chart to control 
the store’s lighting and started this chart by adding commands to PAC Control’s built-in Powerup 
chart. Though your Lighting_Control chart runs, it lacks logic to control anything. In this lesson you 
will add logic that:

• Turns on the inside light.

• Reads the photo sensor and uses its state to control the outside light.

• Reports the state of the Freezer door through the Freezer Door Status light.

• Reports the state of the Emergency switch through the Alarm light.
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Activity

Building the Chart
1. Open Convenience Store.idb in PAC Control, if it is not already open.
2. Under the Strategy Tree, expand the Charts folder and double-click Lighting_Control.
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3. Adjust the window if necessary.
4. Change any preferences, if desired.

Notice that in the example above and used 
throughout, the following has been done:

– The Strategy Tree has been docked (dock the 
Strategy Tree by clicking the dock button ( ).

– The grid and block numbers have been turned 
off using the Configure Flowchart Properties 
dialog box.

– The flowchart window has been maximized.

Review: Configuring 
Flowchart Properties
1. Right-click the flowchart window.
2. Click Flowchart Properties.
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I. Add Action and Condition Blocks

Add Action and Condition blocks so that your flowchart appears as shown below (The names of the 
blocks are not important, as you will change these in the next step):

II. Rename Blocks
Click the Select tool and rename each block as shown below:

Review

Review
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III. Connect the Blocks

Connect the blocks, as shown below:

TIP: You can create corners with the Connect Tool. 
While drawing a connection line, any click on the chart 
window (not on a chart object) will place a corner. 
Each time you click the mouse, PAC Control will anchor 
the connection line. If you have not completed the 
connection line by clicking a block, you can undo a 
connection anchor by right clicking.

Review: Connecting Condition Blocks
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IV. Add Instruction to Action Block: Turn On Inside Light

1. Choose the Select tool.
2. Double-click the Turn On Inside Light block. 
3. From the Instructions dialog box, click Add.

4. Select the Turn On instruction.
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5. Select Digital Output under Type.
6. Select Inside_Light under Name.
7. Close the Add Instruction dialog box.

Your instruction should appear as shown here:

8. Close the Instructions dialog box.

V. Add Instruction to Condition Block: Is It Day?

This block will check the state of the photo sensor. If the photo sensor is on, it is day; if off, it is night.
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Double-click the Is It Day? block. 

From the Instructions dialog box, click Add.

1. Enter the following information:

Instruction: On?

Comment: On = Day; Off = Night

Type: Digital Input

Name: Photo_Sensor

2. Click OK to close the Add Instruction dialog box.

Your instruction should appear as shown here:
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3. Click Close to close the Instructions dialog box.

VI. Add Instruction to Action Block: Configure Lights for Night Mode

1. Double-click the Configure Lights for Night Mode block. 
2. From the Instructions dialog box, click Add.

3. Enter the following information:

Instruction: Turn On

Type: Digital Output

Name: Outside_Light

4. Click OK to close the Add Instruction dialog box.

Your instruction should appear as shown here:
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5. Click Close to close the Instructions dialog box.

VII. Add instruction to Action Block: Configure Lights for Day Mode

1. Double-click the Configure Lights for Day Mode block. 
2. From the Instructions dialog box, click Add.

3. Enter the following information:

Instruction: Turn Off

Type: Digital Output

Name: Outside_Light

4. Close the Add Instruction dialog box.

Your instruction should appear as shown here:
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5. Close the Instructions dialog box.

VIII. Add instruction to Action Block: Wait 15 Minutes

In this step you create a delay. If the strategy were monitoring a real photo sensor for a gradual 
change from day to night, you might use a 15-minute delay. As this would be too long to observe 
the effect of your PAC Control strategy, we will use a 2-second delay instead.
1. Double-click the Wait 15 Minutes block.
2. From the Instructions dialog box, click Add.

3. Enter the following information: 

Instruction: Delay (Sec) 

NOTE: PAC Control provides a Delay (Sec) and a Delay (mSec) command.

Comment: Fifteen minutes = 900 seconds; use a variable to 
contain the seconds.
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Type: Float Variable

Name: Lighting Control Scan Interval.

4. Click OK. 

A prompt asks you to confirm the addition of a variable.

5. Click Yes.

The Add Variable dialog box appears.

6. In the Add Variable dialog box, enter 2 for Initial Value.

7. Click OK to add the new variable.
8. Close the Add Instruction dialog box.

Your command should appear as shown here:

9. Close the Instructions dialog box.

Variables vs. Literals: 
When designating a delay 
interval, you could have 
used a literal instead of a 
variable. The literal can be 
changed by editing the 
flowchart instruction. The 
variable offers more 
flexibility: It can be changed 
by your strategy, by an 
operator using PAC Display, 
or by you in Debug mode.
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Configuring Debug Mode
You use Debug mode to monitor your strategy while it is running on the SNAP PAC I/O unit for the 
purpose of testing your strategy. PAC Control has two levels of Debug, Minimal Debug and Full 
Debug. Minimal debug provides a smaller feature set but allows PAC Control to run faster while in 
Debug mode. Full Debug offers all Debug features but takes longer to download and may slow the 
program significantly. In most applications, however, you are unlikely to notice a big difference in 
performance between the two modes.

Making sure PAC Control is in Minimal Debug mode, choose Configure > Minimal Debug.

Downloading and Running the Strategy

I. Download and Run the Strategy

1. Select Debug from the Mode menu. 

The strategy will be saved, compiled, and downloaded to the control engine.

2. Acknowledge all download messages.
3. Click the Run button to start the strategy.

II. Test the Strategy

1. The Inside Light LED should be ON.
2. Turn on the Photo Sensor Day Mode switch on the load panel (toggle switch to the down 

position). Observe the Outside Light turn off.

A photo sensor is ON when it is daylight. By turning the switch on, you are simulating daylight.

3. Turn off the Photo Sensor switch on the load panel.
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III. Observe the Outside Light turn On

Using Auto Stepping

I. Observe the Strategy Execution in Auto Step Mode

1. Verify that the Lighting_Control chart is running and selected (click within the chart window).

Auto Step Tool: Use 
to put the selected chart 
into Auto Step mode.

Breakpoint Tool: Use to 
place stopping points in Auto 
Step mode.  (Use right-click to 
turn off the Breakpoint tool.)

Step Out: Use when a chart is paused, to execute 
remaining instructions within the current action or 
script block and to stop at the next block.

Step Over: Use when a chart is paused, to execute all 
instructions in the current block and to stop at the next block.

Step Into: Use when a chart is paused, to step through 
individual instructions within action blocks and through 
individual lines within script blocks.

Debugging Tools:
Now that your strategy performs actual logic, you can see the debugging tools in action.

Pause: Use to stop 
a strategy without 
resetting variables 
and output points.

NOTE: Step Into and Step Out are only available in Full Debug mode.

Start and Stop: 
Use to start and 
stop the strategy
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2. Click the Auto Step Chart button (or choose Debug > Auto Step Chart).

Watch the execution of the Lighting_Control chart. Each block becomes cross-hatched as it is 
executed.

3. Turn on the Photo Sensor Day Mode switch and watch the execution of the chart change.
4. Turn off the Photo Sensor Day Mode switch.

You may notice that the outside light (digital output Outside_Light) takes longer to respond to 
a change in the photo sensor (digital input Photo_Sensor). Auto stepping slows down the 
chart’s execution. Once the chart is taken out of Auto Step mode, the chart will execute in real 
time.
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II. Set a Breakpoint

Your strategy will run till it reaches the breakpoint in the Is It Day? condition block:

Observe that the execution of this flowchart stops at the breakpoint. The instructions in the Is It Day? 
block have not been executed at this point. The status of the debugging activities is shown at the 

1. Click the 
Breakpoint tool.

2. Click the Is It Day? 
condition block
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bottom of the chart window. Step On and Break On indicate that the chart is paused and a 
breakpoint has been placed.

Also notice that the pause button is engaged. To continue Auto Step mode, remove the paused 
state by clicking the Pause button. To continue to the next block, click the Step Over button.

Clicking a block in the flowchart will add or remove breakpoints, as long as the Breakpoint tool 
remains selected. You can add and remove breakpoints with your strategy stopped or running.

Using Step Buttons
The PAC Control debugger provides three tools for stepping though components of a chart: Step 
Into, Step Over, and Step Out.

1. To enter Step On mode, click the Pause button.

Notice that the status changes to Step On in the bottom left of the chart 
window.

2. Click the Step Over button several times and watch the execution progress 
one block at a time.

3. To remove the breakpoint, select the Breakpoint Tool, and then click the Is It Day? block.

Notice that the status changes to Break Off.

4. Click the Pause button to continue chart execution. 

NOTE: Step Into 
and Step Out are 
only available in 
Full Debug mode.

Step Into takes you into the instructions 
within the selected block.

Step Out takes you out of the block you 
have stepped into and to the next block. 
The remaining instructions in the same 
block still run.

Step Over takes you to the next block. The 
instructions within the block still run, but 
the logic pauses at the block.

Pause button off (Strategy 
is running)

Pause button on (Strategy 
is stopped)

Debug Tools
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Modifying the Lighting_Control Chart
In this section, you will rewrite the Lighting_Control chart so that it uses fewer commands. You want 
the outside light’s state to be opposite the Photo Sensor’s state. This can be achieved with the Not 
command that writes the inverse of an on/off value to a point or variable.

As you learn PAC Control you will discover many commands that simplify your flowchart design. You 
will also learn that since PAC Control is such a flexible, powerful programming language, there’s 
more than one way of designing any chart.

I. Modify the Chart

1. To return to Configure mode, select Configure from the Mode menu, or click the Configure 
mode button.

2. Modify your Lighting_Control chart as shown here by deleting the unneeded blocks and 
reconnecting the flow lines:

3. Try to revise your Lighting_Control chart on your own, applying the skills you’ve learned. Refer 
to the following diagrams if you need assistance. Once you’ve finished this task, continue to
“II. Add an Instruction to the Control Lights Action Block” on page 113.

Remove these 
blocks. (Select the 
blocks and press 
the delete key.)

To revise the chart:
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II. Add an Instruction to the Control Lights Action Block

1. Double-click the Control Lights block with the Select tool to open the Instructions dialog box.
2. Click Add to open the Add Instruction dialog box.

Click the Select tool and 
rename the new block. 
(Right-click the block and 
choose Name.)

Place a new 
instruction block.

Reposition the 
blocks using 
the Select tool. Click the Connect 

tool and add 
connection lines
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3. Select NOT from the Instruction drop-down list.

The NOT instruction copies the inverse of information from one variable or I/O point to another.

4. Choose Digital Input (Type) and Photo_Sensor (Name) for the first parameter.

The command will read the state of the Photo_Sensor.

5. Select Digital Output (Type) and Outside_Light (Name) for the second parameter.

The command will write the inverse, or opposite, state of Photo_Sensor to Outside_Light.

6. Close all dialog boxes.

Debugging the Changes
1. Select Debug from the Mode menu to return to Debug mode.
2. Acknowledge all download messages.
3. Click the Run button.
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Now you are ready to test the strategy.

4. Turn on the Photo Sensor Day Mode switch on the load panel (toggle switch in down position). 
Observe the Outside Light turn off.

5. Turn off the Photo Sensor Day Mode on the load panel. Observe the Outside Light turn on.

Forcing Outputs and Inputs in Debug Mode
Your inside light and outside light are controlled by the Lighting_Control chart. The diagram below 
shows what takes place between the devices on the load panel and the logic you built in the chart. 
There are two values for each point, an IVAL (for internal value) and an XVAL (for external value). You 
will now learn how to use these values for debugging.

In our scenario, we change night and day with a switch on the load panel. If you were using a real, 
installed photo sensor, you wouldn’t be able to control night and day to test your programming. In 
this case, you can use Debug mode to disconnect the IVAL from the XVAL and simulate inputs to 
observe your program’s responses.

Before continuing, make sure you understand the logic of the chart.
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I. View the I/O Unit

1. Make sure you are in Debug mode.
2. Expand the I/O Units folder in the Strategy Tree.
3. Double-click Points.

4. On the load panel, turn the POS switch on and off. 

– Observe the IVAL and XVAL for the POS point as you turn the POS switch on and off.

– Notice that the XVAL changes but the IVAL doesn’t. The IVAL is unchanged because the 
POS point is not referenced within the strategy.

– Observe the IVAL and XVAL for the Photo_Sensor point as you turn the Photo Sensor 
switch on and off. 

– Both the IVAL and XVAL of the Photo_Sensor change because this point is referenced in the 
strategy.

II. Turn off Inside_Light

1. Double-click Inside_Light.
2. In the View Digital Point dialog box, click the maximize button.
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3. Click the slider arrows next to the XVAL field. This changes the XVAL from On to Off.
4. Click Apply.
5. Notice that the Inside Light LED is off and stays off. 
6. Close the View Digital Point dialog box.

III. Turn Outside_Light On and Off

1. Turn on the Outside Light by turning off the Photo Sensor Day Mode switch (the switch will be 
in its up position).

2. Open and expand the View dialog boxes for the Outside_Light.

3. Use the XVAL field in the View Digital Point dialog box to turn off the Outside Light.
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4. Repeat this a few times.

Notice that the Outside Light turned off for a moment and was then turned on. This is because 
PAC Control is programmed to turn off the Outside Light if the Photo Sensor switch is on.

IV. Disable Outside_Light

If you disable the point, you can prevent the strategy from writing to the XVAL of the Outside_Light. 
Once disabled, you can control the point.
1. Set the Enable Comm field to No, by clicking the Up/Down arrows next to the Enable field.
2. Click Apply.

This breaks the link between the software and the hardware. PAC Control cannot write to the 
XVAL of a disabled point.

3. Turn the Photo Sensor switch on and off. Notice the IVAL for the outside light changes. Because 
the point is disabled though, the XVAL, and therefore the outside light, does not change.

4. Turn the XVAL on and off a few times. (Click the Up/Down arrows to choose On or Off and then 
click Apply.)



4: PAC CONTROL—DIGITAL CONTROL

SNAP PAC Learning Center User’s Guide 119119

Since the point is disabled, you can force the output on or off. PAC Control is setting the IVAL to 
On, according to its logic, but this state isn’t reaching the point, allowing you to turn the point 
on and off using the XVAL. This is because PAC Control is programmed to turn on the outside 
light if the photo sensor is turned off.

5. Change the Enable Comm setting back to Yes.

When communication is enabled, both the XVAL and IVAL change when the photo sensor 
switch is turned on and off. When communication is disabled, the XVAL changes but the IVAL 
does not.

6. Close the View dialog box for Outside_Light.

NOTE: You can open more than one View dialog box for points, but in this activity, it is recommended that 
you keep only one of these dialog boxes open at a time to ensure that you are disabling and writing to the 
correct point.

V. Force Input Point

Now you will disable an input point so you can see your logic react to a simulated input. The ability 
to simulate conditions is a very powerful programming tool.
1. Make sure that your Outside_Light is enabled and the dialog boxes for Inside_Light and 

Outside_Light are closed.
2. Open and expand the View dialog box for the Photo_Sensor.
3. Disable the point Photo_Sensor by selecting Disabled in the Enable Comm field and clicking 

Apply.

NOTE: As the photo sensor is an input, you cannot change its XVAL from PAC Control. Instead, you will 
change the IVAL, which is the value that PAC Control reads.

4. Toggle the state of the IVAL and click Apply. The Outside Light should also toggle.
5. Re-enable communication for the Photo_Sensor point and close its View dialog box.
6. Turn the Photo Sensor switch on and off. Notice that the XVAL changes, but the IVAL doesn’t.
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Adding Control for the Freezer_Door and the Emergency 
Switch
Follow the next steps to modify the existing chart to complete the remaining digital control 
functions:

• Monitor the freezer door switch (Freezer_Door) and display the status on an LED 
(Freezer_Door_Status).

• Monitor the emergency switch (Emergency) and trigger the buzzer (Alarm).

I. Modify the Lighting_Control Chart

1. Choose Mode > Configure to Return to Configure mode.
2. Double-click the Control Lights Action block.
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You will add two Move commands to this instruction block. The Move command is very 
versatile, as it allows you to read or copy information from a variety of data types.

3. Add the two Move commands shown below:

These instructions will connect the Freezer_Door input to the Freezer_Door_Status output and 
the Alarm input to the Emergency alarm output.
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II. Download and Run the Modified Strategy

1. Choose Mode > Debug.
2. Acknowledge the download messages.
3. Choose Debug > Run.

III. Test the Strategy

1. Press and hold the Emergency button to trigger the alarm. 

The Alarm button must be pressed while the program loops into the Control Lights block.

2. Once the alarm is on, release the Alarm switch. 

Within two seconds the alarm will be turned off.

3. Turn on the Freezer Door switch to trigger the Freezer Door Status light.
4. To return to Configure mode, choose Configure under the Mode menu.

You will further modify this strategy in Lesson 5, but will not make any more changes to the 
Lighting_Control chart. Below is a follow-up activity to try on your own to practice the skills you 
learned in this lesson.

Follow-up
The strategy you just built monitors three input points and uses the state of these points to control 
three output points. The strategy achieves this in a loop that checks and writes to points and then 
pauses before repeating. In this lesson, we controlled the pause through a variable with the value of 
2. A 15-minute delay was adequate for automating the outdoor lights, but is much too long for the 
Emergency and Freezer door inputs. A simple way to solve this is to put the functions in a different 
chart according to the length of pause the function needs.

This solution is using PAC Control’s multitasking. You can create many independent charts and up to 
16 can run simultaneously.

How would you make this change to your strategy? One method is described below.

Creating separate charts:
1. Create a new chart named Frequent_Monitor.
2. Copy the flowchart blocks Wait 15 Minutes and Control Lights... from Lighting_Control and 

paste them into the Frequent_Monitor chart.

In Frequent_Monitor chart:
3. Rename the Control Lights... block to Monitor Emergency and Freezer Door.
4. Edit the Wait instruction so that the delay is 2 seconds: for example, use a string literal set to 2, 

or create a new variable with an initial value of 2.
5. Connect Block 0 to the Wait block and connect the Wait block to Monitor Emergency and 

Freezer Door.
6. Open the details of Monitor Emergency and Freezer Door and delete the Control Lights 

command (the NOT command). Make no changes to the Move commands.
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In Lighting_Control chart:
7. View the details of the Control Lights block and remove the Move commands for the 

Freezer_Door and the Alarm.

Variables:
8. Set the initial value of Lighting_Control_Scan_Interval to 900 (15 minutes). You can edit this 

variable from the Strategy Tree.

In Powerup chart:
9. Add a new command to the Start Chart blocks, starting the Frequent_Monitor chart.
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Chapter 5V.Analog
Chapter 5

5: PAC Control—Analog Control

Skills
Analog points

• Referencing analog I/O

• Using variable and literal floats

Debugging

• Changing variable values in real time

• Using Watch Windows

Scenario
In this lesson, you will use the SNAP PAC I/O unit to control analog values and to sound an alarm 
when the fuel tank level is low.
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Our digital controls are taken care of for the moment. The Lighting_Control chart provides the 
following control: your outside light responds to the daylight; your inside light is on when the 
system is running; your freezer door notifies the store attendant when it’s left open; and an alarm 
sounds when a switch is pressed. These activities continue, untouched by the new programming 
you’ll add. The chart you create in this lesson will do the following:

• Read the level of the fuel tank (simulated by the Tank Level potentiometer).

• Display the current level of the tank on the store attendant’s monitor (simulated by the meter).

• Evaluate the tank level.

• Respond to a low level with a brief alarm.

• Repeat at a reasonable interval (using a delay command).

Concepts

Watch Windows
In this lesson you will use a Watch Window as a debugging tool. Watch Windows allow you to 
preserve a list of variables that you need to examine together. 
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A Watch Window is saved as a separate file, and if left open during Debug mode, it is automatically 
opened when you return to Debug mode.

Watch Windows are easy to create and also allow you to open scanning dialog boxes to write to 
variables or points.

Scanning dialog 
boxes are closed 
when you exit 
Debug mode. Each 
item must be 
opened and closed 
individually.

Watch Windows 
can contain any 
data from the 
strategy and are 
saved under a 
unique file name. 
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Activity

Creating a Fuel Monitor Flowchart 
Make sure you are in Configure mode. Select Mode > Configure.
1. Select Chart > New.
2. Name the new chart Fuel_Monitor.

3. Click OK to close the Add New Chart dialog box.
4. Create the flowchart as shown here:

Review: Chart Tools

Use the selection tool to 
manipulate flowchart objects

Chart objects: Once selected, each of 
these tools places its corresponding 
object until you choose the Select tool 
or a different chart object tool.
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Review: Renaming a Block

Review: Connecting blocks
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Reading and Displaying Fuel Levels
Follow the steps below to create a block with an instruction that moves the value of analog input 
point Fuel_Level to analog output point Fuel_Display.

NOTE: You could also move the value of the I/O to a variable in your strategy. This would be advantageous 
when you want to minimize the frequency with which the control engine scans the I/O. By storing an I/O 
state in a variable, you can reference the variable, rather than the I/O, each time you need the value. This 
minimizes the number of times that the I/O point is polled and cuts down on communication time.

Summary of Steps:
1. Double-click Display Tank Level.
2. Click Add.
3. In the Instruction field, select the Move 
command.
4. In the From field, select Analog Input–
Fuel_Level.
5. In the To field, select Analog Output–
Fuel_Display.
6. Close the Edit Instruction dialog box.
7. Close the Instructions dialog box.
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Evaluating the Tank Level
Now you will create an instruction for the Fuel Level Low? block that compares Fuel_Level with the 
variable Fuel_Low_Limit. If Fuel_Level is less than the Fuel_Low_Limit, the block exits true.
1. Double-click Fuel Level Low?
2. Enter the instruction shown below. 

Summary of Steps:
NOTE: The instruction set for a 
Condition block is different from the 
instruction set for an Action block.
1. Create a Condition command:

Command: Less Than or Equal?
Is–Type: Analog Input
Is–Name: Fuel_Level
To–Type: Float Variable
To–Name: Fuel_Low_Limit

2. Create new float variable:
Fuel_Low_Limit
Set initial value to 1000.
Enable Initialize on strategy download.
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Sounding an Alarm
In this section you will create three instructions for the Sound Alarm block. The first instruction turns 
on the alarm. The second instruction inserts a short delay (so that the alarm is not immediately 
turned off ). The third instruction turns off the alarm.

Use the skills you’ve learned so far to create these instructions in the Sound Alarm block:

Summary of Steps: Turn on the alarm

1. In the Instructions dialog 
box, click Add to open the 
Add Instruction dialog box.

2. In the Edit Instruction 
dialog box:

Select the instruction 
Turn On.
Select Digital Output–Alarm.
Click OK.
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Repeating at a Reasonable Interval
Now you will create a delay instruction.
1. Double-click the Delay action block.
2. Enter the instruction shown below

Summary of Steps: Delay

1. In the Instructions dialog box, 
click Add to open the Add 
Instruction dialog box.

2. In the Edit Instruction dialog box:
Select the instruction Delay (mSec).
NOTE: Make sure you choose 
Delay (mSec) and not Delay (Sec).
Select Integer 32 Literal and enter 
the value 100.
Click OK.

Summary of Steps: Turn off the alarm

1. In the Instructions dialog box, 
click Add to open the Add 
Instruction dialog box.

2. In the Edit Instruction dialog box:
Select the instruction Turn Off.
Select Digital Output–Alarm.
Click OK.
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Starting the Fuel Monitor Chart
Remember: Only the Powerup chart starts automatically upon running the strategy. You need to put 
a command in the Powerup chart to start the Fuel Monitor Chart. 
1. If the Powerup chart is open, click the Powerup tab at the bottom of the PAC Control window. If 

it is not open, double-click Powerup in the Charts folder in the Strategy Tree.
2. Add the Start Chart instruction for the Fuel_Monitor chart as shown here.

Summary of Steps

Create a Delay instruction:
1.  Select the instruction Delay (Sec).

NOTE: Make sure you choose Delay (Sec) 
and not Delay (mSec).

2.  Create a new float variable named 
Fuel_Monitor_Delay.

3.  Assign an initial value of 5.

(In reality, you’d want to use a longer delay 
so you wouldn’t get an alarm every 5 
seconds telling you that the fuel is low.)



5: PAC CONTROL—ANALOG CONTROL

SNAP PAC Learning Center User’s Guide 135135

3. Close the Add Instruction dialog box.
4. Close the Start Charts Instructions dialog box.
5. Save your strategy.

Downloading and Testing Your Strategy
Your revised strategy now turns on a brief alarm 
when fuel levels reach 1000 gallons or lower. 
1. On the Learning Center load panel, set the 

Tank Level potentiometer to midrange.
2. Download and run your strategy.
3. View the Fuel Monitor chart.

If the Fuel_Monitor chart is open, click the Fuel_Monitor tab at the bottom of the PAC Control 
window. If it is not open, double-click Fuel_Monitor in the Charts folder in the Strategy Tree.

4. If you would like to view the execution of the flowchart, Turn on Auto Stepping.
a. Click the Fuel_Monitor chart.
b. Choose Debug > Auto Step Chart.

5. To test the strategy, turn the Fuel potentiometer knob counterclockwise, and watch the needle 
on the Fuel Display meter track the value (with a five-second delay).

When the value of the tank level is less than the low tank limit of 1000 (represented by 1 on the 
meter scale), the alarm sounds.

6. Now turn the fuel level potentiometer to below 1000.

As long as the tank level is below 1000 gallons, the SNAP PAC I/O unit will sound an alarm every 
five seconds.

NOTE: By default, PAC Control does not 
automatically run the strategy on powerup. 
You can change this setting in the Download–
Flash Memory options, available through File 
> Strategy Options.
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Changing the Value of Fuel_Low_Limit in Real Time
The low level value used to determine when to sound the alarm is contained in the variable 
Fuel_Low_Limit. You can change the variable in Debug mode.

To open the View Variable dialog box for Fuel_Low_Limit:
1. Make sure that your strategy is still running and PAC Control is in Debug mode.
2. In the Strategy Tree, expand the Variables folder.
3. Expand the Numerical Variables folder.
4. Double-click Fuel_Low_Limit.
5. Expand the View Variable dialog box.
6. Type 2000 in the Value field.
7. Click Apply.
8. Verify that the alarm sounds any time fuel level is below 2000.

NOTE: The variable Fuel_Low_Limit is initiated on strategy download. If you stop and restart the 
strategy, the value will remain 2000. However, if you download the strategy, the value will be 
initialized to 1000.

Leave the Fuel_Low_Limit View Variable dialog box open; you will use it to create a Watch 
Window.

Using Watch Windows
A Watch Window allows you to monitor numerous strategy elements simultaneously and save the 
window for reuse. You can monitor I/O units, digital and analog points, event/reactions, variables, 
and even charts in a Watch Window.

Unlike Inspection Windows (such as, View Variable windows), Watch Windows

• can be created the way you want
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• can be docked in a position most convenient for you

• are saved with your strategy. 

You cannot change strategy elements in a Watch Window, but you can open the Inspect dialog box 
from the Watch Window to change the element.

I. Add a Variable to the Watch Window

1. In the Fuel_Low_Limit inspect dialog, click Watch.

2. Click New to create a new Watch Window.
3. Navigate, if necessary, to the SNAP PAC Learning Center directory. 

For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC Learning Center

4. Type DebugFuelMonitor in the File name field.

5. Click Open.
6. Click OK to close the Add Watch Entry dialog box.

The new Watch Window appears.
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II. Arrange Your Workspace

1. Notice the Dock, Minimize, and Maximize buttons in the top right-hand corner of the Watch 
Window.

2. Click the Dock button ( ).

The Watch Window is now docked at the bottom of your workspace as shown below.

3. Close the View Variable dialog box.

Dock button
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III. Add variables to the Watch Window.

Click and drag Fuel_Monitor_Delay to the Watch Window.

You can add additional items to the watch window by clicking any tag in the Strategy Tree and 
dragging it to the Watch Window.

IV. Add Fuel Level to the Watch Window

1. Open the I/O Units folder in the Strategy Tree.
2. Expand folders until the I/O points are shown.
3. Click and drag Fuel_Level to the Watch Window.

Click and drag 
Fuel_Monitor_Delay
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V. Experiment with the Watch Windows

Here are a few things you can do:

• Close the Watch Window. To reopen, select Watch > Debug Fuel Monitor from the top menu.

• Delete an item. Just highlight a tag name, right-click, and select Delete.

• Move an item up or down in the list. Highlight a tag name, right-click, and select Move Up or 
Move Down (or click and drag a tag name).

• Open an inspect dialog by double-clicking a tag name.
1. Close the Watch Window.

Your Watch Window is saved. You can create additional Watch Windows.

2. Return to Configure mode.

In Lesson 6 you will revise your Fuel_Monitor chart. Leave PAC Control and your strategy open if you 
plan to continue to the next lesson.
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Chapter 6w
Chapter 6

6: PAC Control—OptoScript

Skills
OptoScript

• Creating OptoScript blocks

• Using variables

• Using analog points

• Using commands in OptoScript

• Using the OptoScript reference library

• Writing conditional statements

• Using OptoScript’s test compiler

Debugging OptoScript

• Setting Full Debug option

• Stepping line by line

Scenario
The chart you created in the previous exercise displays the fuel level on your meter and checks the 
level against the minimum defined by the variable Fuel_Low_Limit. To demonstrate OptoScript, 
we’re going to rewrite the chart using one OptoScript block.

Concepts

OptoScript
OptoScript blocks contain code written in OptoScript, a programming language that:

• is based on C, Pascal, and Basic

• offers the same commands used in other flowchart blocks

• provides online scripting assistance in choosing commands and strategy variables
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• checks script syntax

OptoScript is an optional programming language that can simplify certain types of operations in 
PAC Control, giving you an alternative to using standard PAC Control commands.

OptoScript does not add new functions, but offers an alternative method of programming. 
OptoScript code cannot be mixed with commands in Action or Condition blocks; rather, it is used in 
its own hexagonal block.

You’ll want to use OptoScript for programming tasks that can be more difficult or time consuming 
using standard PAC Control commands. For example, extensive math calculations and complex 
loops can take up a lot of space on a flowchart.

OptoScript is especially useful for the following:

• Math expressions

• String handling

• Complex loops

• Case statements

• Conditions

• Combining all of the above

Two methods of programming in PAC Control:
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Activity

Creating an OptoScript Block
1. Make sure you are in Configure mode and the Fuel_Monitor chart is open.
2. Click the OptoScript Block tool.
3. Click in the Fuel_Monitor chart to place the OptoScript block as shown:

When we are finished with this block, it will replace the flowchart we created in the previous 
lesson. Typically, you would not program an entire flowchart in one OptoScript block. You 
would normally use OptoScript blocks in conjunction with action and condition blocks. The 
purpose of this activity is to illustrate how to use OptoScript, and to show that, because it is 
more compact, it can replace several blocks.

4. To open the OptoScript editor, choose the Select tool and double-click the OptoScript Block.
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5. Type the comments shown here. (Comments are very important in OptoScript blocks, enabling 
you and others to return to the code and quickly understand the programming logic.)

Features of the OptoScript Editor:

Action Commands: Provides 
access to OptoScript version of 
all action commands. 

Condition Commands: Provides 
access to OptoScript version of all 
condition commands. 

Variables: Provides access to all variables 
that have been defined. To use variables 
in OptoScript, the variables must have 
been created already in PAC Control.

Test Compile: OptoScript blocks are 
compiled when the rest of the strategy is 
compiled (for example, upon downloading). 
Test Compile checks the syntax of the script.

Comments: Lines beginning with // 
are comments, which PAC Control 
ignores when the script is compiled. 
Comments are displayed in green. You 
can also use /* and */ to comment 
several lines of code.
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Continue with the next section.

Using Variables in OptoScript
The entire strategy database, which includes I/O points, charts, and variables, is available to 
OptoScript. All are treated as variables within the OptoScript editor. Variables must be created in PAC 
Control before using the OptoScript editor. You cannot create variables on the fly from within an 
OptoScript block. They must already exist in your strategy. But, unlike other programming 
languages, you do not have to declare variables before you use them in an OptoScript block. 

In this first line we want to move the value of the analog input point Fuel_Level to the analog 
output point Fuel_Display. 

I: Insert the Analog Output Variable, Fuel_Display

1. Place your typing cursor below the text //Display Fuel Level.
2. Click the Insert Variable button to open the Select Variable dialog 

box.
3. Select Analog Output in the Type field.

As Fuel_Display is the only Analog Output variable, it should be selected.
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4. Click OK.

Fuel_Display will appear in the OptoScript Editor.

5. Type an equal sign (=) after Fuel_Display.

NOTE: Spacing is optional, but makes your code easier to read.
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II: Insert the Analog Input Variable

1. Make sure the typing cursor is after the equal sign.
2. Open the Select Variable dialog box.
3. In the Type field, choose Analog Input.
4. In the Name field, choose Fuel_Level.

5. Click OK.
6. Type a semicolon at the end of the line.

Using Action Commands in OptoScript
In the next series of steps you will learn how to select Action commands and to use the Command 
help. We will create a delay command to execute a five-second delay between loops that check the 
need to turn on the outside lights. (In a real application, we would use a longer delay, such as 15 
minutes.)

PAC Control Commands and OptoScript

Some PAC Control commands have a matching OptoScript 
command, which we’ll use shortly. Some are accomplished 
without a command by using the built-in functionality. For 
example, instead of using an ADD command, you would just 
use a plus symbol (+). These are documented in the PAC 
Control User’s Guide, in the OptoScript Command Equivalents 
Appendix. If we looked in that appendix, we’d see that instead 
of MOVE, we use an equal sign (=).
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I: Insert the Action Command

1. Move the typing cursor to the line below the //Delay comment. (Insert a line break if necessary.)

2. Click the Insert Action Command button.

3. In the Groups field, select Timing.

Notice that the there are two delay commands available.
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One of the delay commands is more suitable than the other for the delay we need. You can 
read the help for each command to determine which is better.

II: Use Command Help to Determine the Best Command to Use

1. Select the DelayMsec command.
2. Click Command Help. 

3. Scroll down the help window to the Notes section.

The help says “For readability, use Delay (Sec) for delays longer than 10 seconds.” If we were 
creating a 15-minute delay, we would use Delay (Sec), but since we are using a 5-second delay, 
DelayMsec is the better command to use.

4. Close the Help window.

III: Insert the DelayMsec command

1. From the Select Instruction dialog box, select the DelayMsec command (if it is not already 
selected).
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2. Click OK.
3. Add the parentheses and the milliseconds parameter. Your code should appear as shown here:

DelayMsec(5000) 

NOTE: We could have created an integer variable and used it in place of the 5000.

4. To test compile, click the Test Compile button.

.

The DelayMsec command was incomplete and the test compiler reveals the error.
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IV: Use the Output Window To Locate an Error

The Output window will locate an error for you.
1. Double-click the error message in the Output window.

The source of the error is now highlighted. A semicolon is needed at the end of the DelayMsec 
command.

2. Click at the end of the DelayMsec command to remove the highlighting.
3. Type a semicolon.
4. Repeat the test compile.
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Keep the OptoScript editor open for the next series of steps.

Creating Conditional Statements
Like loops and case statements, conditional logic can be simpler in OptoScript than in flowcharts. 
If/then, if/then/else, and if/then/elseif statements can all be mixed and nested within OptoScript as 
needed. (Note: The syntax is documented in the PAC Control User’s Guide, Opto form #1700. Sample 
code is also included in the PAC Control example strategies.)

I. Create an If/Then Statement

1. Type the partial if/then statement shown below:

Summary of Steps

1. Create the if/then 
structure:
if ( ) then

endif

2. Type or use the Select 
Variable dialog box to 
insert the following 
variables:
Fuel_Level
Fuel_Low_Limit
3. Type <= for less than 
or equal to.
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NOTE: Using Select Variable helps prevent spelling errors.

2. Insert an action command by completing the if/then statement as shown:

II. Increase Indent

The OptoScript editor can adjust the indenting of text to make the code easier to understand.
1. Highlight the lines shown below.
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2. Click the Increase Indent button.

3. Do a test compile ( ).

4. Click Save to close the OptoScript editor.

Modifying the Flowchart
Your OptoScript block is ready to replace your chart.

I. Connect the OptoScript Block

1. Using the select tool ( ), select the connection line between Block 0 and Display Tank Level.

2. Press the Delete key.
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3. Select the Connect tool.
4. Click Block 0 (see diagram below).
5. Click the OptoScript block.
6. Click the OptoScript block again to start the second 

connection.
7. Click above the OptoScript block (this draws the connection line out of the top of the script 

block).
8. Click above Block 0.
9. Click Block 0 (this completes the connection).

It is important to loop the connection lines. This enables the script to run continuously. Without 
looping back to the starting block, the logic would run the script only once, because the script block 
itself contains no looping instructions.

II. Rename Your New Block

1. Click the Select tool.
2. Right-click your OptoScript block.
3. Click Name.
4. Type Monitor Fuel Tank.

Review: Connect Tool
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Debugging OptoScript
Debugging your strategy has new challenges now that you have a script block with several lines of 
code. We’ve been running Debug mode with minimal debug features. Now that we have 
OptoScript to test, we’ll need to use the full set of debug features.
1. Choose menu Configure > Full Debug.

2. Download and run the strategy.

The chart should work just as before.

3. Substep through the Fuel Monitor chart as follows:
a. With your chart still running, place a breakpoint on the Monitor Fuel Tank block.
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b. Wait for the strategy to stop at the script block.
c. Click the Step Into button.

This button opens the OptoScript block window.

Review: Setting a Breakpoint

1. Click the 
Breakpoint 
tool while 
your chart is running.

2. Click the Monitor Fuel Tank block.
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Tabs at the bottom of the window allow you to switch between the OptoScript block and 
the rest of the chart. The OptoScript block window remains open as along as the program 
execution is within this block.
Within the OptoScript block, a red arrow identifies where the program execution is. 
Clicking the Step Into button advances the program through individual commands. The 
Step Over button will advance through looped statements. The Step Out button will 
advance to the next block.

d. Click the Step Into button to see the execution continue line-by-line.
e. Click Step Out to exit this block.

You will notice a pause before the OptoScript window is closed. This is 
because the remaining lines in the OptoScript block include a 5-second 
pause. When the OptoScript block is closed, the programming execution stops at the next 
block, which is Block 0.

4. Remove the breakpoint on your OptoScript block. (With the Breakpoint tool selected, click the 
OptoScript block.) Then click the pause button.

Returning to Configure Mode
1. Leave your strategy running.

You will need your strategy running for the next lesson on PAC Display.

2. Return to Configure mode.
a. Choose menu command Mode > Configure.
b. Click Yes to take the chart out of Step mode.

3. Save your strategy.
4. Close PAC Control.

This completes the PAC Control portion of the tutorial. While the instruction so far is not 
comprehensive, it does introduce you to many important concepts and features. To learn more, 
consult the PAC Control User’s Guide or the Opto 22 website. Of course, the best way to continue 
learning is to begin programming your own applications.

The program execution is 
still paused, waiting for 
Step commands to 
continue. Alternatively, 
you can remove the 
paused state, which will 
continue to the next 
breakpoint.
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Chapter 7
Chapter 7

7: PAC Display—Operator 
Interfaces

Skills
Creating a Project

• Configuring a control engine

• Connecting to a PAC Control strategy

Simple Graphics and Text

• Importing bitmaps

• Importing Symbol Factory graphics

• Drawing shapes

• Creating text

• Duplicating graphics

Formatting

• Aligning graphics and text

• Changing font styles

Dynamic Graphics and Text

• Using analog values to resize and recolor graphics

• Displaying analog values as text

• Using digital values to control the appearance of graphics

• Displaying digital states as text

• Writing to a digital point

Scenario
Your PAC Control strategy is complete and running on the SNAP PAC I/O unit in your convenience 
store. The following capabilities are available:

• The inside lighting is turned on when the strategy starts running.

• The photo sensor triggers the outside lighting.

• The freezer door switch controls the freezer door status light.
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• The emergency button triggers the alarm.

• The tank meter displays the value of the tank level potentiometer using a scale of 0–10,000 
gallons and sounds the alarm if the level is below 1000.

The operation of your SNAP PAC I/O unit is independent of your workstation. You used your 
workstation to monitor the programming and to debug the code. Though you can follow the 
control logic using Debug mode, PAC Control is not a suitable interface for an operator who 
monitors a process. It’s much more useful to create graphical and text displays in PAC Display that 
represent your system. In this lesson, you use your workstation as part of a process monitoring 
system that you build.

PAC Display is a process visualization program that reads from and writes to the tags in one or more 
PAC Control strategies. The result is a graphical user interface that you design to meet your needs, 
whether you are trying to visualize a complex process or summarize the key elements of one in an 
operator interface. This type of tool is often referred to as a monitoring application, or a human–
machine interface (HMI).

In this lesson, you create a graphical user interface to monitor the following from your convenience 
store:

• Level of the fuel tank

• State of indoor and outdoor lighting.
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Concepts

PAC Display within Your SNAP PAC System

PAC Display Capabilities
PAC Display is a software application specifically designed for use with PAC Control. PAC Display 
allows easy interaction between a process operator and the PAC Control strategy running on a SNAP 
PAC controller. PAC Display can interface with a single control engine or with multiple control 
engines, each running a different PAC Control strategy.

PAC Display connects to a tag database, which contains the readable and writable elements in a PAC 
Control strategy. By connecting tags to graphical objects that you draw, you can create on-screen 
animations that represent the process running on your SNAP PAC R unit and provide operator 
controls. You can configure a graphic to reflect the state or value of a tag, write to a tag, or both. For 
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example, you can use the value of an analog point to change the color, size, position, or visibility of a 
graphic. You can also use graphics that the operator can select to write changes to tags, for example, 
clicking on a graphic of a light switch to turn on a light.

Connecting graphics to tags is a simple process due to PAC Display’s tight integration with PAC 
Control. This integration eliminates the need to retype data into a tag dictionary, a requirement with 
many other HMI programs. Other PAC Display capabilities include real-time trending, historic data 
logging, application launching, file uploading and downloading, and multimedia support.

Control vs. Monitoring
Control and monitoring (or interfacing) are two very distinct aspects of your system. Opto 22 draws 
a line that separates the control of your system from the user interface that interacts with your 
system.

Control
PAC Control is a process control language. The strategy that you develop is used to control your 
system.

Monitoring

PAC Display is a software application used to create an operator interface for a PAC Control strategy. 
PAC Display does not control your system. It is an interface tool. The project that you develop using 
PAC Display monitors the PAC Control strategy as it is running. PAC Display can be used to change 
the values of tags in the PAC Control strategy, but it does not contain programming or logic-solving 
capabilities to actually control the process.

Configurator vs. Runtime
PAC Display has two separate programs: Configurator and Runtime.

Configurator

The Configurator defines and configures the PAC Display windows, graphics, dynamic attributes, 
logs, alarms, and sounds that make up your project. The objects are connected to variables, I/O 
points, PID loops, or other tags defined in your PAC Control strategy. Every PAC Control strategy 
stores information on global data items for that strategy in a file with the extension *.IDB. PAC 
Display can link to any PAC Control strategy through its *.IDB file.

Runtime
PAC Display Runtime communicates with the processor running the PAC Control strategy. Runtime 
animates the operator interface by updating the graphic attributes (color, size, position, and 
visibility) in response to changes in the PAC Control tags.

Objects
A PAC Display project consists of many objects. Objects include drawing windows, graphics, alarm 
triggers, and trends. Objects can be either static or dynamic.
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Static Objects

Static objects are not attached to PAC Control tags and have no dynamic attributes. Their 
appearance does not change while PAC Display Runtime is running. Examples of static objects are 
labels and backgrounds.

Dynamic Objects
Dynamic objects have attributes that can change the appearance of objects in PAC Display. 
Attributes can also change the value of variables or states of I/O points in a PAC Control strategy. In 
other words, dynamic attributes can be used to read tags, write to tags, or both.

Tags
A tag represents data items (such as points and variables) that have been configured in a PAC 
Control strategy.

To animate your operator interface, PAC Display graphics are connected to tags and assigned 
graphic dynamic attributes. Dynamic attributes are used to change the appearance of the graphic in 
response to a tag’s change in value (control engine-driven attribute), or are used to change the 
value of a tag (operator-driven attribute).

Tags are also used as triggers to initiate system events such as sounds, historic logging, and window 
configurations.

Activity

Preparing for the Lesson
Make sure your PAC Control strategy is loaded and running on the SNAP PAC controller.

You can use the PAC Project utility PAC Terminal to check whether your strategy is running:
1. Start PAC Terminal.

From the Start menu, select All Programs > Opto 22 > PAC Project [version number]> Tools > 
PAC Terminal.

2. Double-click the name of the control engine to open the Inspecting window.



ACTIVITY

SNAP PAC Learning Center User’s Guide164

The name and operational state of the strategy is shown in the Strategy Info group. A running 
strategy is indicated by Running in the Status field and the Run button is selected. You can use 
the Run button to start the strategy if it is not running.

Creating a PAC Display Project
1. From the Start menu, select All Programs > Opto 22 > PAC Project [version number]> PAC 

Display Configurator Basic.
2. Select File > New Project to open the New Project window.
3. Navigate to the SNAP PAC Learning Center directory. 

For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC Learning Center
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4. Type Monitor Convenience Store in the File name field. This will be the name of your 
PAC Display project.

5. Click Open. 

The Control Engines dialog box appears.

6. Continue with the next section.

Linking the Control Engine
The building blocks of PAC Display projects are the I/O point and variable tags used by a PAC Control 
strategy. You gain access to these tags by linking the project to a control engine. 

Linking to a control engine is a two-step process: 1) you specify the PAC Control strategy running on 
the control engine; then 2) you select or create the control engine configuration on the PC.
1. In the Control Engines dialog box you opened in the previous section, click the Add button.



ACTIVITY

SNAP PAC Learning Center User’s Guide166

2. Browse to the SNAP PAC Learning Center directory.

For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC Learning Center

3. Select and open Convenience Store.idb. 

After providing the tag database, the Control Engine Properties dialog box appears for you to 
specify the control engine.

The *.idb file is a database of all tags used in the specified PAC Control strategy. PAC Display 
links directly to the file. There is no need to re-enter tag names.

4. Click the Browse button to select a Primary Control Engine.

Your strategy (tag database) is 
listed here.

Click here to specify a 
control engine.
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5. Select the SNAP PAC control engine.
6. Click OK to close the Select Control Engine dialog box.
7. Click OK to close the Control Engine Properties dialog box.
8. Click OK to close the Control Engines dialog box.

Changing the Properties of the Drawing Window
Your new project contains a drawing window, which will become part of the operator interface you 
are building. The Tools palette provides access to the various PAC Display objects you can create. 

If the Tools palette is covering your drawing window, drag the Tools palette to another part of the 
application window.

1. Select Window > Properties to open the Window Properties dialog box.

The properties of the drawing window describe the size, color, position, and behavior of the 
window.

PAC Display Configurator

The drawing window has 
editable properties governing 
its default size, location, 
background colors, menu 
features, etc., that can a be 
edited from the Window 
menu.

Drawing Window: Drawing 
windows contain the operator 
interface (the HMI) that you are 
building. You can create any 
number of drawing windows.

Tool palette: The Tool palette 
contains the objects you put 
into your operator interface.
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2. Type Main in the Name field. 

Every window that you create in the project has its own unique name. You will use this window 
as the main window in your project. In this window, you can create buttons to open and close 
other windows.

3. Type 0 in both the X Position and Y Position fields. 

The position 0,0 indicates that the top-left corner of the window will be placed at the top-left 
corner of your computer screen.

4. Type 800 in the Width field.
5. Type 600 in the Height field.

Specifying 800 x 600 creates a full-screen window when the resolution of the monitor is 800 by 
600. The window can be enlarged later if the specified dimensions do not produce the desired 
size on your workstation. (However, it is difficult to reduce your project if it gets used on a 
system of lower resolution.)

6. Click the System menu option box so that it is checked.

This option provides Minimize and Maximize buttons, along with a System Menu button on the 
left side of the window.

7. Click the Always in memory (fastest access) option box in the Runtime Options field. 
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8. Click the Background Color box.
9. Select a light color by clicking on it.
10. Click OK to close the Color dialog box.
11. Click OK to close the Window Properties dialog box.
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Examining the Tools Palette
Now, you will begin drawing and selecting objects for your user interface. Take a few moments to 
examine the Tools window and become familiar with the function of each tool.

Always in memory specifies that this window's information should be loaded and always saved in the PAC 
Display computer's memory during Runtime. Normally, only opened or iconified windows are saved in memory. 
Use this option for a window you know will be opened and closed often, as it will save time when the window 
is opened. (There are trade-offs when using this option: the more windows you have with this option selected, 
the more computer memory is used and the more time your initial PAC Display setup will take. Having fewer 

windows with this option uses less computer 
memory, speeds up the initial PAC Display setup, 
but costs you time when a window is opened.)

The Password Protect button lets you 
assign a password to a window. When a password 
is assigned to a drawing window, a closed window 
cannot be opened until the operator supplies the 
password. Open windows that are iconified or 
hidden are not affected. You cannot assign a 
password to a window that both contains an alarm 
and has the Runtime option “Open when there are 
new alarms” selected.

The Select tool is used to select one or more objects in the drawing window. 
Objects must be selected before you can change their properties, attach tags, or 
delete or move them.

The Line, Rectangle, Round Rectangle, and Ellipse are used to create the 
shape indicated by the tool name. To draw the object, position the cursor in the 
drawing window; press and hold the left mouse button as you drag the mouse 
and form the desired shape. To draw a straight horizontal or vertical line, a 
perfect square (or square with rounded corners), or an exact circle, hold the 
Ctrl key down while drawing the object.

The Free-Style Polygon and Free-Style Line tools are used to draw complex 
shapes and lines. Apply a click-and-drag motion to draw and complete the 
object by double-clicking the last point you draw. The easiest way to draw a 
precise shape is to use one of these tools to establish the number of points, and 
then use the Select tool to right-click the object and choose Edit Points.

The Free-Style Curve tool draws curves that you can reshape. Draw a curve by 
clicking four places approximating your curve. The first click establishes the first 
end point. The second click places an attractor that governs the curve from the 
first end point. The third click places an attractor for the fourth endpoint. To edit 
the curve, use the Select tool to right-click your curve and choose Edit Points.
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The Bitmap tool is used to paste selected bitmaps. To use this tool, you must first 
load a bitmap using File > Choose Bitmap.

The Text tool is used to create text in a drawing window. Text can be a static 
object (a label) or a dynamic object (display a value). To use this tool, you 1) select 
the tool, 2) click in a drawing window, 3) type the text, 4) and click again in the 
drawing window. To edit text, use the Select tool to select and right-click the text.

The Trend tool is used to create real-time trends. As with all dynamic objects, the 
attributes of the trend are determined after the trend is drawn in the window.

The SuperTrend tool is used to create trends that can be real-time, historical, or 
both. The SuperTrend has all the features of a regular trend, plus many more. 
SuperTrends can be disabled or hidden.

The Alarm tool is used to create alarm graphics. As with all dynamic objects, the 
attributes of the alarm graphic are determined after the graphic is drawn in the 
window. These graphics can be used to display notifications of alarms.

The XY Trend tool is used to create an XY plot from two numeric tables of data.

The Numeric Table tool creates a table that displays the contents of PAC 
Control float tables, integer 32 tables, and integer 64 tables.

The Scale Window tool The Scale Window tool allows you to resize a 
window and the graphics inside at the same time.

NOTE: Resizing graphics in this manner is not exact. Graphics are resized in 
units of whole-number percentages, not fractional percentages, and the 
vertical and horizontal dimensions are resized independently. So if a window 
is returned to its original size after it has been modified, it may not look 
exactly the same as it did before it was resized. Also, resizing a window using 
this method cannot be undone.

The Button Control tool adds an unlabeled Windows button to the active 
display window.

The Combo Box Control tool adds a Windows combo box to the active 
display.
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Creating an LED Display
This diagram shows the information flow behind the dynamic LED display you will create in the 
following steps:
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I. Create an LED

1. Select the Circle tool from the Tools window.
2. While holding the Ctrl key, click and drag the mouse to create a circle.

The dynamic properties of this graphic will be added later.

II. Create Dynamic Text

1. Choose the Text tool.
2. Click below the circle and type #.
3. Click below the # to anchor the text.

The pound symbol (#) is a special character in PAC Display that is used within text fields to 
display values. The dynamic properties of this text field will be added later.



ACTIVITY

SNAP PAC Learning Center User’s Guide174

III. Create a Text Label

1. With the Text tool still selected, click above the circle. 
2. Type Inside Light and then click elsewhere to anchor the text.

IV. Align the Objects

1. Choose the Select tool. 
2. Click and drag a rectangle around all three objects to select them.
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3. Right-click the items, and from the pop-up menu, select Align > Center.

Animating the Light
Once an object is drawn, the next step is to assign attributes for the object. Attributes determine 
how that object reacts to its linked tag. An object can change appearance or position in response to 
a change in the tag value. An object can also be used by an operator to send information to a tag.

I. Configure the Circle
For the first attribute, you will configure the circle to be solid red when the light is on.
1. Click an empty work space to deselect the three objects.
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2. Double-click the circle, select Fill Color under Control Engine Driven Attributes.

3. Click Edit (under Control Engine Driven Attributes) to open the Dynamic Attribute dialog box.

4. In the Setup By field, select Discrete, and then click the Tag Selection button ( ).

This opens the Discrete Tag Selection dialog box.
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5. Select the following items:

Item Type: Digital Output Point.

Item Name: Inside_Light

NOTE: All of the digital output points that were configured in your PAC Control strategy are listed in the 
Item Name field. Because PAC Display and PAC Control share a database, tag names do not need to 
be re-entered, merely selected.

6. Click OK to close the Discrete Tag Selection dialog box.
7. In the Discrete field on the Fill Color dialog box, click the black box underneath ON to open the 

Color dialog box. 
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NOTE: In the Dynamic Attributes dialog box, it is very important to select either the Value or Discrete 
option in the Setup By box, as this choice affects the tags that will be available to this dynamic object. 
For example, if you chose Current Value, you would not be able to select a digital point.

8. Select a bright red, and click OK to close the Color dialog box.
9. Click OK to close the Dynamic Attribute dialog box.

Leave the Graphic Dynamic Attributes dialog box open.

II. Select An Operator-driven Attribute

Now you will add an operator-driven attribute that will turn the light off and on when the operator 
clicks the circle.
1. In the Graphic Dynamic Attributes dialog box, select Send Discrete, then click Edit.
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2. Click the Tag Selection button ( ) to open the Discrete Tag Selection dialog box.

3. Select the following items:

Item Type: Digital Output Point.

Item Name: Inside_Light
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4. Click OK.
5. In the Dynamic Attribute dialog box, select Toggle, then click OK.

6. Click OK to close the Graphic Dynamic Attributes dialog box.

Animating the Text
Next, you will configure the string underneath the light to display On or Off, depending on the state 
of the light.
1. Double-click the pound sign (#) to open the Graphic Dynamic Attributes dialog box.

.

2. Double-click Text in from Control Engine to open the Dynamic Attribute dialog box.



7: PAC DISPLAY—OPERATOR INTERFACES

SNAP PAC Learning Center User’s Guide 181181

3. In the Setup By field, select Discrete, then click the Tag Selection button to open the Discrete 
Tag Selection dialog box.

4. Select the following items:

Item Type: Digital Output Point.

Item Name: Inside_Light.

NOTE: Digital Output Point is available only if you select Discrete in the previous dialog box.

5. Click OK to close the Discrete Tag Selection dialog box.
6. In the Dynamic Attributes dialog box, enter the following:

Text Justification: Select Center.

On: Type ON.

Off: Type OFF.
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NOTE: Any text can be put in the On and Off fields, such as Open and Closed, Running and Stopped.

7. Click OK to close the Dynamic Attribute dialog box.
8. Click OK to close the Graphic Dynamic Attributes dialog box.

Making a Duplicate LED Display for the Outside Light
1. Select the circle and two text fields by doing either of the following:

– Using the Select tool, click and drag a rectangular area embracing the three objects.

– Click the first object and then shift-click the remaining two.
2. Right-click the selected objects, and choose Duplicate.
3. Drag the new objects to the right. (Move the tool palette if it is in your way.)

4. Click in the window to deselect the objects.
5. Click the Inside Light label. 

CAUTION: Do not group objects with dynamic attributes. It is tempting to group the 
objects, but this will change the discrete objects with unique graphical dynamic 
attributes into one object with no graphical dynamic attributes. You can assign 
dynamic attributes to a group and to individual objects, but assigned attributes are 
not preserved when you group or ungroup a set of objects.
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6. Right-click the Inside Light label, choose Edit Text, and then type Outside Light.

7. Click OK.

Attaching the Outside Light to Tag
The outside light has the same dynamic attributes as the inside light. You only need to change the 
tags used by the control engine-driven and operator-driven attributes.

I. Configure the Outside Light Graphic

1. Double-click the Outside Light circle to open the Graphic Dynamic Attributes dialog box. 
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2. Under Control Engine Driven Attributes, double-click Fill Color.

3. In the Dynamic Attribute dialog box, click the Tag Selection button ( ).
4. Under Item Name, select Outside_Light.
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5. Click OK to close the Discrete Tag Selection dialog box.
6. Click OK to close the Dynamic Attribute – Fill Color dialog box, but leave the Graphic Dynamic 

Attributes dialog box open.

II. Change the Operator-Driven Attribute
Although we are configuring this graphic with an operator-driven attribute, the digital output point 
the light is connected to is controlled by the PAC Control strategy. If the Digital_Control chart is 
running, the state of the Photo_Sensor switch, not the operator, will continue to determine whether 
the outside light is on or off. (You might also choose to delete or disable the operator-driven 
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attribute by simply unchecking the box next to Send Discrete. You might also wish to keep this 
attribute to provide a way of controlling the lights if you stop the PAC Control strategy.)
1. In the Graphic Dynamic Attributes dialog box, double-click the Send Discrete attribute to open 

the Dynamic Attribute dialog box.
2. Click the Tag Selection button.

3. Select Outside_Light.
4. Close all dialog boxes.

III. Attach the Outside Light Text to a Tag

1. Double-click the outside light’s dynamic text field.

2. In the Graphic Dynamic Attributes dialog box, double-click Text in from Control Engine to open 
the Dynamic Attributes dialog box.
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3. Click the Tag Selection button, and then select Outside_Light in the Discrete Tag Selection 
dialog box.

4. Close all dialog boxes.

IV. Check the Assigned Tags

Using tooltips you can identify which tags are assigned to an object.
1. Click an object.
2. Hover the cursor over the clicked object until a tooltips message appears.
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Testing the Project

I. Run the Project

1. Select File > Save Project and Load Runtime to run your project.

Your PAC Display project is automatically loaded and the Event Log Viewer window appears. 
Use this dialog box to confirm a successful connection to your control engine.

2. Click Close to close the Event Log Viewer.
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II. Use the Operator Interface

1. Turn on and off the Photo Sensor switch on the load panel.

The change in state of the outside light (triggered by the Photo Sensor switch) shows red and 
black and ON and OFF. 

2. Click the Inside Light LED in your project window.

This will turn off the Inside Light on your load panel.

3. Click the Inside Light LED again, and the Inside Light turns off.
4. Click the Outside Light LED in your project window. 

You will not be able to change the state of the light for very long. (Remember: PAC Control is 
controlling this light based on the state of the photo sensor.)

5. Choose File > Exit PAC Display Runtime.
6. Click Yes to acknowledge the Exit PAC Display Runtime message.

Creating a Tank Level Display
You will create a tank graphic with a bar graph that moves up and down proportionally to reflect the 
level of the tank.
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I. Locate the Tank Graphic from Symbol Factory

First you will import a picture of a tank picture from the Symbol Factory, which is a graphics library 
built into PAC Display. The Symbol Factory is a library of over 3,000 symbols for industrial 
automation, including pumps, pipes, valves, tanks, mixers, motors, ducts, electrical symbols, flow 
meters, material handling, sensors, PLCs, transmitters, and ISA symbols.
1. Select Edit > Paste from File > Symbol Factory.

2. Select Tanks in the Categories field.
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II. Change the Options for a Symbol Factory Graphic

1. Click a tank to select it.
2. Click Options.
3. Select Shaded from the Fill Color Mode menu.
4. Click the Fill Color box and choose a color.
5. Click the Defaults button if you wish to restore the image.
6. Click OK to close the Symbol Options dialog box.

Click here to see the 
options for any selected 
graphic. (You can copy 
the tank as it is shown, or 
you can choose options 
to change the color, 
background, and 
orientation of the tank.)

Find the Tanks category among 
64 categories of symbols.
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III. Paste the Symbol Factory Graphic into PAC 
Display

1. Make sure the tank you want to paste into PAC Display is 
selected.

2. Right-click the tank.
3. Click Copy as Picture (wmf ) Only.
4. Close the Symbol Factory by clicking the X in the upper 

right-hand corner.
5. Click anywhere in the Main drawing window to make 

PAC Display the active application.
6. Right-click in the Main window and select Paste.

IV. Resize the Tank Graphic

1. Choose the Select tool.
2. Click and drag the tank to the lower left-hand side of the window.
3. Resize the tank by moving your cursor over one of the size handles, clicking and dragging the 

mouse. Release the mouse when the tank is the desired size.

Note: Symbol Factory will 
copy graphics as either a 
bitmap or a WMF file. To 
change the file type that is 
copied by default—for 
example, to remove the 
square border of a 
bitmap—in Symbol 
Factory, see Options > 
Configure.
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V. Create a Dynamic Rectangle

1. Select the Rectangle tool from the Tools window.
2. Position the mouse over the tank.
3. Click and hold the left mouse button.
4. While holding the mouse button, move the mouse in a diagonal motion to create a rectangle. 

When the rectangle has the desired shape, release the mouse button.

VI. Adjust Size and Placement

1. Choose the Select tool.

Resizing a Graphic:

Move the hand cursor to the 
lower-right drag handle (one 
of eight small boxes 
indicating selection).

When the cursor changes to an 
arrow, click the handle and drag to 
resize the graphic.
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2. If necessary, resize the rectangle or center it on the tank. You can also use the arrow keys on 
your keyboard to move a selected object.

Assigning Dynamic Attributes

I. Add a Vertical Size Graphic Dynamic Attribute

1. Double-click the rectangle.
2. In the Graphic Dynamic Attributes dialog box, double-click Vertical Size (height) as the 

attribute.

II. Assign a Tag

1. Click the Tag Selection button.
2. In the Item Type list, select Analog Input Point.
3. In the Item Name list, select Fuel_Level.
4. Click OK to close the Value Tag Selection dialog box.
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III. Enter the Height Scaling

1. Type 10000 in the Maximum Value 
field.

2. Type 0 in the Minimum Value field.

You have chosen the full range of 
values to monitor for this tag (0–
10,000). An object does not have to 
monitor the entire range of values. 
A subset of values can be 
monitored.

3. Type 100 in the Max Percent 
Height field. 

This field is used to specify the maximum percent height size that the graphic may achieve 
relative to its size in the Configurator. This percentage is achieved when the tag (Fuel_Level) 
returns data that is greater than or equal to the Maximum Value.

4. Type 0 in the Min Percent Height field. 

This field specifies that the object will be 0 percent of its current size when Fuel_Level returns a 
value less than or equal to the Minimum Value (in this case, 0).

5. Select the Bottom option in the Anchor field. 

The bottom edge of the graphic remains fixed as the object changes size.

6. Click OK to close the Dynamic Attribute–Height dialog box. 

(Leave the Graphic Dynamic Attributes dialog box open.)
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IV. Add the Fill Color Graphic Dynamic Attribute

1. Double-click the Fill Color attribute to open the Dynamic Attribute–Fill Color dialog box.

2. Make sure that Current Value is selected under Setup By.

V. Assign a Tag

1. Click the Tag Selection button.
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2. In the Item Type list, select Analog Input Point.
3. In the Item Name list, select Fuel_Level.
4. Click OK.

VI. Configure a Color Change

You can configure the Fill Color of the tank to be based on I/O values. For example, if the tank level is 
less than 1000 gallons, the level indicator could change to red.

In the Dynamic Attribute–Fill Color dialog box, type the following cutoff values, left to right in the 
order shown here:

VII. Assign Colors to Each Range

1. Click the left color box (which corresponds to the lowest range).
2. In the Color dialog box, click a red color.

1000 2000 5000 9000
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3. Click OK to close the Color dialog box.
4. Repeat the above steps for the remaining ranges, assigning the following colors:

1000 < 2000: Yellow

2000 < 5000: Green

5000 < 9000: Blue

9000 <: Blue

5. When you’ve assigned colors to all five ranges, click OK to close all dialog boxes.

VIII. Verify the Tags Assigned to Your Graphic
You can place the selection cursor over a graphic to read the tags assigned to it.
1. Click the rectangle.
2. Place the cursor over the rectangle.

Using Imported Bitmaps in a Graphical Display
In this section, you will bring in a bitmap to use as a display. The built-in graphic support includes a 
selection of *.bmp (bitmap) files. You can also use a bitmap created in other programs. In this 
example, we created a faceplate bitmap for you to use.

Both tags should 
be as shown here.
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I. Load the Bitmap

1. Select Choose Bitmap from the File menu.

2. Navigate to the SNAP PAC Learning Center directory. 

For example, C:\Users\Public\Documents\Opto 22\PAC Project 9.6\SNAP PAC Learning Center

3. Double-click Faceplate.bmp.

The bitmap graphic Faceplate.bmp is now loaded. Every time you use the Bitmap tool on the Tools 
Palette, you will place this graphic until you repeat these steps to load a different graphic.

II. Place a Bitmap Graphic

1. Choose the Bitmap tool from the Tools window.
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2. Click below the bar graph to place the bitmap.
3. If you need to move the bitmap, click the Select tool, and click and drag the bitmap to the 

desired location. 

NOTE: You can also move a selected object using the arrow keys.

III. Create Text Label

1. Select the Text tool from the Tools window.
2. Click anywhere in the drawing window.
3. In the text box, type ##### Gal.

4. Click elsewhere in the drawing window to complete the entry of the text.

You could just type one #. However, by typing five characters (one for each digit in the 
maximum tank size) you can adjust the font and spacing so that the tank level reading will fit in 
the display box throughout the entire range. The # character also allows you to format a 
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decimal point. For example, if you want two decimal places to be shown, you would type 
#####.##.

IV. Make the Text Bold

1. Choose the Select tool and select the text.
2. Right-click the text.
3. Select Bold from the Style menu.

V. Drag the Text to the Display

1. Place the mouse over the text.
2. Click and hold the left mouse button.
3. Drag the mouse to move the text to the display 

bitmap.
4. Release the mouse button when the text is in the 

desired place.
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VI. Align the Display and Text

1. Click elsewhere in the 
window to release any 
selected objects.

2. Select the text and bitmap.
3. Right-click the selected 

objects.
4. Select Align and then Center 

from the pop-up menu. 
5. Right-click the selected 

objects again to open the 
same pop-up menu.

6. Select Align and then Middle. 

This selection aligns the 
selected graphics along a 
middle horizontal axis.

VII. Assign a Tag to the 
Tank Level Display

1. Click elsewhere in the 
drawing window to deselect the bitmap and the text.

2. Double-click the text to open the Graphic Dynamic Attributes dialog box.
3. Double-click Text in from Control Engine.

VIII. Assign the Tag

In the Value Tag Selection dialog box, do the following:
1. Make sure Value is selected under Setup By.
2. Click the Tag Selection button.
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3. In the Item Type field, select Analog Input Point.
4. In the Item Name field, select Fuel_Level.
5. Click OK to close the Value Tag Selection dialog box.

In the Dynamic Attribute dialog box, do 
the following:
6. For Text Justification, choose Right.
7. Click OK to close the Dynamic 

Attribute dialog box.
8. Close the Graphic Dynamic 

Attributes dialog box.

Running Your Project
1. To save your work and go to PAC 

Display Runtime, select File > Save Project and Load Runtime.

If you are making many modifications to a PAC Display project, it is advisable to save the project 
at least every 15 to 30 minutes.

2. Click Close to close the Event Log Viewer.
3. Rotate the tank level counter-clockwise.

Notice that the bar graph gets smaller and changes color. The numerical value displayed on the 
bitmap graphic also changes.

4. Turn on the Photo Sensor switch.
5. Rotate the potentiometer clockwise. 

The bar graph gets larger.
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6. Turn on and off the Photo Sensor switch and observe the outside light graphic change color.
7. Select Exit PAC Display Runtime from the File menu.
8. When asked if you want to exit Runtime, select Yes.

Setting Refresh Times
When you rotated the tank level potentiometer, you may have observed that the display in your HMI 
did not keep up with changes to the potentiometer. In this step, you will improve your HMI’s 
performance by changing the properties of a scan group. 

A scan group defines how often control engine variables are scanned to refresh PAC Display 
graphics. Every PAC Display tag is assigned a scan group when the tag is selected. There are 14 scan 
groups with configurable refresh times. Refresh times range from milliseconds to months. 
Communication loads can be optimized by carefully defining and assigning refresh times.
1. Select Refresh Times from the Configure menu to open the Refresh Times dialog box.

2. To change the refresh time for Group 0:

– For Group 0, type 100 in the Scan Rate – Value field.

– In the Scan Rate – Units field, select Milliseconds.
3. Click OK to close the Refresh Times dialog box.
4. Select Save Project and Load Runtime from the File menu.
5. Click Close to close the Event Log Viewer.
6. Test the project by rotating the tank level knobs.

Notice that the bar graph responds much faster. This is because you changed the rate at which 
the tag values are updated.

7. When you are finished, choose Exit PAC Display Runtime from the File menu.
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Chapter 8
Chapter 8

8: PAC Display—Trending

Skills
SuperTrends

• Drawing a SuperTrend object

• Defining trend attributes and scaling

• Configuring trend pens

• Using historical and real-time modes

• Opening historic logs

Operator Interface

• Creating a new window

• Opening and closing windows

• Configuring Runtime options

• Password protecting a window

• Assigning operator-driven attributes

Scenario
You now have an operator interface for a computer connected to your SNAP PAC I/O unit. Someone 
at this computer can monitor devices in the convenience store and control certain points, such as 
the indoor lighting. This operator interface is a window to the process being controlled by the SNAP 
PAC, and the capabilities of this interface are determined by the developer using PAC Display 
Configurator.

In this lesson, you will enhance the monitoring capabilities of your operator interface by using PAC 
Display’s trending features. Trends allow you to monitor and record changes in values over time. 
Specifically, your operator interface will be tracking Fuel_Level and Store_Temperature.
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Concepts

SuperTrends
The PAC Display Tools palette provides Trend, X-Y plot, and SuperTrend tools. Of these, the 
SuperTrend is the most sophisticated. Using the SuperTrend tool, you draw SuperTrend graphics just 
as you would any other graphic; however, once created, a SuperTrend allows you to define 
numerous attributes of a dual-axis graph, where the X-axis is always time and the Y-axis is a scale 
you define. SuperTrends can contain up to 16 tags and display your tags in real-time and historical 
modes.
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Historical mode creates log files that can be opened at any time for analysis.

About PAC Display Windows
In this and the following lesson, you will add additional windows to your project. As you work in PAC 
Display Configurator, the appearance of your project closely mimics the runtime result. It is easy to 
forget that some features in the PAC Display Configurator user interface are actually controlling the 
PAC Display Runtime interface. For example, if you open a window to contain the SuperTrend you 
will build in this lesson, you should make a decision as to whether you want this window open all 
the time or just upon certain actions. If you leave it open in Configurator, it will be open by default in 
Runtime. It may be inconvenient to have to open or close your windows to ensure the desired 
defaults in runtime, so PAC Control gives you a way of configuring the default state of each window. 
The location of the configuration settings is shown below:
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Windows can be opened or closed as needed by the Window menu and as an operator driven 
attribute. Here are some techniques to remember when working with multiple windows in PAC 
Display Configurator:

Features used to set the default states of windows:
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Activity

Preparing for the Lesson
Make sure your PAC Control strategy is loaded and running on the SNAP PAC controller.

You can use the PAC Project utility PAC Terminal to check if your strategy is running. (See 
page 7-163).

Make sure PAC Display is running and your project is open.

Creating a New Window
1. Select Window > New to open the New Window dialog box.

Any windows 
created in the 
project but not 
currently open are 
shown here.

The Copy, Delete, 
and Properties 
options act on 
the currently 
open window.

All open windows in the 
project are listed here.
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2. Provide the following information in the New Window dialog box:

Name field: Trends 

X Position: 5

Y Position: 5

Width: 750

Height: 520

3. Check the System menu option box. 

This option places the control icon in the upper left of the window and the minimize, 
maximize, and close icons in the upper right of the window.

4. Click OK to close the New Window dialog box.

Creating a SuperTrend

I. Draw a SuperTrend

1. Select the SuperTrend tool from the Tools palette.
2. Click and drag in the Trends window to draw the SuperTrend.
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Your SuperTrends graphic should appear as shown here:

Use the Select tool if you need to resize your SuperTrend. In order to match the screen shown 
here, your SuperTrend needs to be wide enough to display all of its icons on one line.



ACTIVITY

SNAP PAC Learning Center User’s Guide212

II. Open the SuperTrend Setup Options

1. Choose the Select tool.
2. Double-click the SuperTrend.

3. In the Trend Type field, make sure that Combined is selected. 

This SuperTrend will plot both real-time and historical data.

4. In the Refresh Time field, select Group 2. 
5. In the Disable Scanning field, select Never. 

III. Change SuperTrend Background Color

1. Click the Color – Background box. 

About Scanning
A trend continuously polls for data unless it is disabled. There are options to 
disable the trend when the window is closed and/or iconified. These options 
improve efficiency when numerous trends are used. If every trend is continually 
scanning, the system throughput is slowed. Disabling the scanning reduces the 
communications overhead between PAC Display and the control engine.

When a trend is disabled, it does not plot data. When the trend is re-enabled, 
scanning begins automatically, but there will be a gap in the trend data.

In this example, we are using one SuperTrend that monitors gradual change. So 
there is no need to optimize performance.
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This opens the Color dialog box.

IV. Select X-axis Options

1. Click the X-axis tab.
2. In the Time Span field, enter 30 

Seconds.

The trend will display 30 seconds of 
data at one time.

3. In the Major divisions field, enter 15 
Seconds.

The trend will have a major division 
every 15 seconds.

4. In the Minor divisions field, type 3.

Each major division will have 3 minor 
divisions. For this example, there will be 
a minor division every 5 seconds.

5. In the Colors section, change the Major divisions color to black, the Minor divisions color to 
white, and the Labels color to dark gray. These colors provide good contrast to the light gray 
background of the trend.

2. Choose a light gray 
color.

3. Click OK to close 
the Color dialog 
box.
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V. Select Y-axis Options

1. Select the Y-axis tab.
2. In the Grid section, type 4 in the Major 

divisions field and 5 in the Minor 
divisions field.

3. Under Scale make sure the Scaling is 
set to Pen. 

4. In the Colors section, change the Major 
divisions color to black and change the 
Minor divisions color to white. 

5. For the Labels color, select the Active 
Pen Color option.

The labels color will be the same as the 
color used to plot a selected tag.

VI. Select Zoom Options
The Zoom options allow you to configure the zoom levels for the X-axis in historical mode.

1. Select the Zoom tab.

The Zoom In level lets you look at a 
more detailed section of a historic log. 
The Zoom Out level lets you look at a 
less detailed section of a historic log.

2. In the Zoom In section, enter 15 
Seconds as the Time Span.

The Time Span is the amount of time 
displayed in the grid when in Zoom In 
mode. 

3. Enter 5 Seconds as the Major 
division and 5 seconds as the 
Minor division. 

4. In the Zoom Out section, enter 10 Minutes as the Time Span, 2 Minutes as the Major 
division, and 4 as the Minor division. 
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VII. View Hot Keys Configuration 
Options

1. Select the Hot Keys tab.

You can assign a hot key to one of the 
commands listed. In Runtime, typing 
an assigned hot key performs the same 
action as clicking a SuperTrends 
command button.

2. Under Commands, select Historical 
Mode.

3. Under Hot Key select Ctrl.
4. In the Key dropdown list, select H.

VIII. Configure Pen 1

1. Select the Pens 1–8 tab. 

This dialog shows all of the pens, whether or not they are enabled, and the color of the pen. 

2. Click the Modify button for Pen 1.



ACTIVITY

SNAP PAC Learning Center User’s Guide216

3. Click the Tag Selection button.

7. Type Fuel Level for the Name. 

NOTE: You can use spaces in pen names.

8. Type 10000 for the Max Value. 

This value describes the value of the line when it is at the top of the trend.

9. Type 0 for the Min Value. 
10. Select a bright blue color for the Line Color. 
11. Type 3 for the Line Width. 

This value describes the width of the line in pixels.

12. Make sure the Point marker is enabled. 

A marker will be displayed for every scanned point. This feature makes it easy to identify 
scanned data.

13. Click OK close the SuperTrend Pen 1 dialog box.

4. Select Analog Input Point 
in the Item Type field.

5. Select Fuel_Level in the 
Item Name field.

6. Click OK to close the Value 
Tag Selection dialog box.
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IX. Configure Pen 2

1. Configure Pen 2 just as you did with Pen 1, but enter the following information:

Name: Store Temperature

Tag (Open the Value Tag Selection dialog box):

Item Type: Analog Input

Item Name: Store_Temperature

Field: Value

NOTE: Value is not the default selection with this point. Make sure you choose Value under the Field 
item.

Max Value: 100 

Min Value: 0 

Line Color: Red

Line Width: 2

2. Disable the Point marker.

3. Click OK to close the SuperTrend Pen 2 dialog box.
4. On the SuperTrend dialog box, verify that you have two pens configured and enabled.

Point 
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5. Click OK.

A message on memory usage by the new SuperTrend is shown.

6. Click Yes.

Testing Your Changes

I. Save Your Project and Load PAC Display Runtime

1. Select File > Save Project and Load Runtime.
2. Close the Event Log Viewer.

II. Open the Trends Window

1. Select Window > Open.
2. In the Open Windows dialog box, select Trends, and then click OK.

NOTE: Most of the buttons at the bottom of the trend are disabled. You will use these buttons when 
you switch to the Historic mode later in this exercise.

The scale on the left-hand side of the graph is based on the active pen. The active pen is listed 
in the drop-down box at the bottom of the graph.

3. Rotate the Fuel Level potentiometer and notice the change to the SuperTrend.
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4. Click the drop-down menu at the bottom of the SuperTrend. 
5. Select Store Temperature. 

Notice that the SuperTrend Y-axis is showing a scale of 60 to 100. 

III. Examine the Historic Trend

1. To switch to Historic mode, click the Historic Mode button ( ).

Notice that the scale on the Y-axis 
changed to match the scaling of the 
Store_Temperature tag. The scaling 
was set in PAC Display Configurator, but 
you can change the scaling in Runtime 
by clicking on the Scale button.

6. Click the Scale button.
7. Type 60 in the Minimum Value field.
8. Click OK to close the SuperTrend Pen 

Scale dialog box.
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The SuperTrend Historic Log Files dialog box lists all available SuperTrend files. Start and end 
times are listed for each file, so you can choose the desired file. Because the specified 
SuperTrend file rollover time is longer than the time PAC Display has been trending, you may 
have only one file. 

2. Click the file to select it, and click OK.
3. Experiment with your trend. Scroll forward and backward. Zoom in and out. Change the scale 

by selecting a new active pen.
4. Click on a point marker on the trend plotted by the active pen. PAC Display pops up a box that 

lists the point’s value and time/date stamp.

5. Switch back to the real-time trend by clicking the Real-time Mode button.

Notice that the real-time plot has no gaps in the data. PAC Display continues to record and plot 
data, even while in historic mode.
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NOTE: If your SuperTrend is not displaying a tag, you may have not scaled the pen correctly. For 
example, if a tag’s value is 7500, but the scale is the default 0-100, the pen would be off the scale.

IV. Exit Runtime

1. When you are finished, select File > Exit PAC Display Runtime.
2. Click Yes.

Using Windows in the Operator Interface
The SuperTrend is in its own window, and you used PAC Display Runtime’s window menu to view 
the Trends window.

Choosing Window > Trends brought the Trends window to the front. If you closed your Trends 
window in Configurator, closed would have been the default state, and you would have used 
Window > Open to open your Trends window. PAC Display used the last state of the windows as the 
default. 

Next, you will:

• Configure the initial state of the window.

• Add a button within the Main window that opens the Trends window.

• Add Password protection for the Trends window.

I. Password Protect the Trends Window

1. Bring the Trends window to the front, if it is not there already.
2. Choose Window > Properties.
3. Click Password Protect.
4. Type a password in both fields.

NOTE: Passwords are case-sensitive.
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5. Click OK.
6. Close the Windows Properties dialog box.

II. Copy a Button Graphic from Symbol Factory

1. In PAC Display, choose Edit > Paste from File > Symbol Factory.
2. Choose the category Icons and Bitmaps.
3. Select the Chart icon (large) and click Copy.
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4. Close Symbol Factory.

III. Paste the Icon into the Main Window

1. Bring the Main window to the front.
2. Choose Edit > Paste.
3. Drag the graphic to the desired location.
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IV. Assign Operator-Driven Attributes to the Icon

1. Double-click the chart icon.
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2. Double-click Windows (under Operator Driven Attributes) to open the Pop Window dialog box.

V. Open the Runtime Setup Options Dialog Box

We want the Trends window to be closed at startup. 
1. Select Configure > Runtime.

3. In the Windows field, select 
Trends.

The default action Open is 
already selected.

4. Click Append.

The action is now described 
under the Action Affected 
Windows field.

5. Click OK to close all dialog 
boxes.



ACTIVITY

SNAP PAC Learning Center User’s Guide226

3. Click the Define Default button.

2. Under Runtime Draw Window Initial 
State, click Use Default to enable the 
feature.
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The windows you defined are listed in the Windows field. To set a default action for a window, you 
select the window, chose Open, Close, or Iconify, and then click Append.

VI. Define the Default State of the Main Window

1. In the Pop Window dialog box, select Main.
2. In the Default group, select Open.

3. Click Append.

4. Click OK to close the Pop Window dialog box.
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VII. Define Trends Window Caption

Testing Your Changes
1. Choose File > Save Project and Load Runtime.
2. Click your Chart icon.
3. Type your password and click OK.

4. View your trend.
5. Close PAC Display Runtime after viewing your SuperTrend.

1. Under Main Window Style Options, 
select User custom caption.

2. In the Custom Caption field, type 
Convenience Store 1.

3. Click OK to close the Runtime Setup 
dialog box.
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Chapter 9
Chapter 9

9: PAC Display—Alarming

Skills
Alarms

• Configuring alarm points

• Creating alarm graphics

• Using alarm types: Detailed, Summary, History

Operator Interface

• Enabling alarms within a drawing window

• Opening and closing drawing windows

Scenario
In developing your store monitoring system, you may wish to alert the operator to a situation that 
needs action. For example, should the fuel level be low, you would want the operator to arrange a 
fuel delivery. In this lesson, you will create alarms that alert an operator to the following conditions 
that may need human intervention:

• Low fuel level

• Freezer door left open

• Lost connection to the control engine

Concepts

Alarm Points
Alarm points are the basis of the alarming feature. Each alarm point is linked to a PAC Control tag. In 
PAC Display Runtime, the tag value of each alarm point is compared to the configured alarm state. 
When an alarm point is in an alarm state, it is displayed on all alarm graphics that contain that alarm 
point. It will also be sent to any configured file or printer logs. Alarm points are global to a project 
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and can be included in any number of alarm graphics. It is possible that a configured alarm point 
will never be included in an alarm graphic, but its tag will still be scanned and sent to any 
configured file or printer logs. 

Alarm Graphics
An alarm graphic provides the human interface to the alarm points. You create an alarm graphic 
using the Alarm Tools on the tool palette and configure it to contain alarm points. More than one 
alarm graphic can be placed in any PAC Display window and can be resized. Alarm graphics use 
Windows list view controls; for example you can double-click a column heading to sort the list by 
that column’s entries.
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Alarm graphics can display the time and date that the alarm occurred, as well as the name and state 
of the point, its priority, and a comment you define.

There are three types of alarm graphics:

• Detailed—Detailed alarm graphics treat each alarm state as a different alarm condition. For 
example, consider an alarm that went from its normal state to the Hi state, and then to the HiHi 
state. The detailed alarm graphic would have separate alarm notices for both the Hi and HiHi 
alarm states. Both of these states must be acknowledged before they are removed from the 
alarm graphic. 

Detailed alarms have buttons for acknowledging and silencing alarm points. The Acknowledge 
button will acknowledge all selected alarm points. The Acknowledge All button will 
acknowledge all of the alarm points. Silence and Silence All will turn off an alarm until it is 
unsilenced. Hot keys can be configured to Acknowledge, Acknowledge All, Silence, and Silence 
All as well.

• Summary—Summary alarm graphics are similar to detailed alarm graphics, except that only 
the most current state for an alarm point is displayed. For example, suppose an alarm point 
goes from its normal condition to the Hi state. The summary graphic would display the Hi state 
alarm. If the alarm point then enters the HiHi state, the graphic will be updated and display 
only the new HiHi state.

Summary alarms have two buttons to acknowledge alarm points. The Acknowledge button 
will acknowledge all selected points. The Acknowledge All button will acknowledge all of the 
alarm points. Hot keys can be configured to Acknowledge or Acknowledge All as well.

• History—The History alarm graphic displays a log of all its alarm point activity. There are no 
acknowledgement buttons on History alarm graphics.

Alarm tool is used to draw 
alarm graphics.

Alarms contain information from the alarm point configuration and include the time, data, and 
value or state of the alarm point. Column headings also sort the list. 

Alarm Graphics
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File Logging
Alarm points can be logged to a text file. All alarm points are logged. A subset of alarm points 
cannot be specified. 

Printer Logging
Alarm points can be logged to one printer or to multiple printers. These printers must be installed 
on the computer. All alarm points are printed. A subset of alarm points cannot be specified. 

Sounds
PAC Display can be configured to play a sound once when an alarm point enters an alarm state, or to 
play continuously while any alarm points are active. The sound file can be located in the project 
directory or have a fixed path. To use this capability, your PC must have a properly configured sound 
card and driver to support the desired sound file types. Both *.wav and *.mid files are supported.

Activity

Preparing for the Lesson
1. Make sure your PAC Control strategy is downloaded and running on your SNAP PAC controller.
2. Open your PAC Display project in PAC Display Configurator.

Configuring the Fuel Level Alarm Point
The first part of creating alarms is defining the alarm points. An alarm point’s configuration consists 
of the following:

• A tag that you use to indicate an alarm state, for example, Fuel_Level.

• Criteria for evaluating the tag, such as what value for Fuel_Level should trigger an alarm.

• Priority of the alarm. PAC Display lets you prioritize alarm points on a scale of 0–999. 

I. Open the Alarm Points Configuration Dialog Box

Select Configure > Alarm Points.
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II. Create a New Alarm Point

1. Click Add to open the Alarm Point dialog box.

2. Type Fuel Level in the Name field.
3. Under Setup By, choose Current Value. (It should be the default selection.)
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NOTE: It is important that you select the correct Setup By option before selecting a tag, as the Setup 
By option determines which tags will be available.

III. Choose the Tag

1. Click the Tag Selection button to open the Value Tag Selection dialog box.

2. In the Discrete Tag Selection dialog box, select the following:

Control Engine: SNAP PAC.

Item Type: Analog Input Point.

Item Name: Fuel_Level.

Field: Value.

Refresh Time: Group 1.

3. Click OK to close the Value Tag Selection dialog box.

IV. Configure Alarm Values

You will configure this alarm to react to Lo and LoLo regular fuel levels.
1. Click the Value tab.
2. Click the HiHi, Hi, and Normal check boxes to disable alarms for these states.
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V. Assign a Tag to the Alarm Criteria

The Lo alarm will be determined by the value of Fuel_Low_Limit, rather than a fixed value.
1. In the Lo field, select the Tag option. 

NOTE: Selecting a tag allows you to evaluate an alarm state based on a variable. 

2. Click the Tag Selection button.
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3. In the Value Tag Selection dialog box, select the following:

Control Engine: Choose SNAP PAC.

Item Type: Choose Float.

Item Name: Choose Fuel_Low_Limit.

Refresh Time: Choose Group 1.

4. Click OK to close the Value Tag Selection dialog box.

VI. Configure Lo Priority Value and Comment

You can assign a priority to your alarm point on a scale of 0–999. The lowest priority is 0, and the 
highest is 999. (Later, you will see how an operator can filter alarms by their priority settings.)
1. Type 800 in the Priority field.
2. Type Fuel Tank Level Low in the Comment field.

VII. Add Value, Comments, and Priority to LoLo Value

1. Type 500 in the Value field.
2. Type 900 in the Priority field
3. Type Contact Supervisor in the Comment field.
4. Close the Alarm Point dialog box.
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Configuring the Freezer Door Alarm Point
The next alarm point will be a discrete item. We want to be notified if the freezer door is open for 
more the 10 seconds.

I. Create Freezer Door Alarm Point

1. In the Alarm Points dialog box, click Add to open the Alarm Point dialog box.
2. Type Freezer Door Open as the name of this alarm point.

Lo alarm triggered by 
comparison to another 
tag. This value can be 
changed.

LoLo alarm triggered by 
comparison to value 
entered here. This value is 

Literal and Tag-based Alarm Criteria:



ACTIVITY

SNAP PAC Learning Center User’s Guide238

3. Under Setup By, click Discrete.

II. Choose Tag

1. Click the Tag Selection button.
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2. In the Value Tag Selection dialog box, select the following:

Control Engine: SNAP PAC.

Item Type: Digital Input Point.

Item Name: Freezer_Door.

Field: State.

Refresh Time: Group 1.

3. Click OK to close the Value Tag Selection dialog box.

III. Discrete Tag Options

1. Click the Discrete tab.
2. For Alarm when, choose True/On. 

This will put the Freezer Door in an alarm state when it is open. (You can configure a discrete 
alarm state as either On or Off.)

3. In the Priority field, type 775. 
4. In the Comment field, type Freezer Door is Open.
5. Click the More button.
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6. Under Configure Persistence Time, enter 10 Seconds.
7. Click OK.
8. Click OK to close the Alarm Point dialog box.
9. Close the Alarm Points dialog box.

Creating a New Window for Alarm Graphics

Alarms are displayed within alarm graphics that you place in a window. In this section, you will 
create a new window to hold the alarm graphics. The window will be configured to open 
automatically when an alarm occurs and to require the operator to acknowledge the alarm before 
closing the window.

I. Open the Alarm Window Configuration Options

1. Select Window > New.
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2. Type Alarms in the Name field.
3. Type 0 in both the X Position and Y Position fields.
4. Type 800 in the Width field and 600 in the Height field.
5. Select System Menu.

II. Select Runtime Options

1. Check the following boxes in Runtime Options: 

– Always in memory

– Open when there are new alarms

– Disable close if there are active alarms
2. Select Popup as the Behavior. (This means that the window will stay on top of all windows, 

even if the operator clicks on a window behind it.)
3. Select Red as the Background Color.

4. Click OK to close the New Window dialog box.

Creating a Detailed Alarm Graphic
You will create two alarm graphics in the Alarms window. One graphic will be a Detailed alarm, and 
the other will be a History alarm.

I. Draw Alarm Graphics

1. Select the Alarm tool from the Toolbox.
2. Starting in the upper left-hand corner of the Alarms window, click and drag a large rectangle. 

The rectangle should be approximately half the vertical size of the Alarms window.
3. With the Alarm tool still selected, click and drag another rectangle in the lower half of the 

window, to create the second alarm graphic. 
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II. Configure the Alarm Graphic

1. Choose the Select tool. 
2. Double-click the first alarm graphic.
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3. Select Detailed as the Alarm Type. 

Detailed alarms treat each alarm point state as a separate alarm condition. Each alarm point state 
needs to be acknowledged before it is removed from the alarm graphic. Therefore, if an alarm goes 
from Hi to HiHi, both alarm states will be listed. (Summary alarms display only the current state of an 
alarm point.)

III. Add Alarm Points to the Detailed Alarm Graphic

1. In the Alarm Configuration dialog box, click Add.
2. Select both alarm points by clicking one and then shift-clicking the other.

NOTE: Be careful with the Add, Modify, 
and Delete buttons. Add and Modify 
take you to the Alarm Point dialog box 
to add or modify the alarm point. 
Delete will remove alarm points from 
your PAC Display project.

Selecting alarm 
points will 
include them in 
your alarm 
graphic.
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3. Click OK to close the Alarm Points dialog box.
4. Click OK to close the Alarm Configuration Dialog Box.

IV. Adjust Columns

1. To resize a column, move the cursor to the right of the field containing that column’s caption. 
2. When the double-headed arrow appears, click and drag your mouse to the desired width.

Creating a History Alarm Graphic

I. Open the Alarm Configuration Dialog Box

1. Double-click the lower alarm graphic.
2. Select History as the Alarm Type.

NOTE: This Delete 
button removes the 
alarm point from the 
current alarm graphic
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This graphic will display a complete list of all alarms and their status.

II. Add Alarm Points

1. In the Alarm Configuration dialog box, click Add.
2. Select both alarm points by clicking one and then shift-clicking the other.
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3. Click OK to close the Alarm Points dialog box.
4. Click OK to close the Alarm Configuration dialog box.

Creating a Close Window Button
In this section you will create text that will act as a button to close the Alarms window. Creating a 
button involves drawing the object that will be the button and then assigning it an operator-driven 
attribute.

I. Create Text

1. Select the Text tool from the Tools palette.
2. Click in an empty space at the top right of 

the Alarms window. 
3. Type Close Window.
4. Click elsewhere to anchor the text.

II. Format the Text

1. Choose the Select tool from the Toolbox. 
2. Right-click on the Close Window text.
3. From the shortcut menu select Style > 

Bold.
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III. Assign Operator-Driven Attributes

1. Double-click the Close 
Window text to open the 
Graphic Dynamic Attributes 
dialog box.

2. Double-click Windows.
3. Choose Alarms in the 

Windows field.
4. Select Close in the Default 

field.
5. Click Append.
6. Click OK to close the Pop 

Window dialog box.
7. Click OK to close the Graphic 

Dynamic Attributes dialog 
box.
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Examining Alarming Setup Features

I. Configure Alarming Setup

1. Select Configure > Alarming Setup.

2. Under Runtime Options, select the following:

– All alarms enabled at startup

– Alarms Enabled menu item

– Priority Filter menu item 
3. Check all items under User Adjustable.
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About Runtime Options

From the Options page, you can select several runtime settings. 

• If All alarms enabled at startup is checked, all alarms will be enabled as soon as 
PAC Display Runtime connects to the control engine. 

• If Alarms Enabled menu item is checked, the user has access to the Alarms 
Enabled menu item at Runtime. By selecting this menu item, the user can enable or 
disable all alarms. If this item is not checked, the menu item will be grayed out and 
inaccessible. 

• If Priority Filter menu item is checked, the user has access to the Priority Filter 
menu item at Runtime. By selecting this menu item, the user can filter out alarms 
lower than a specified priority. If this item is not checked, the menu item will be 
grayed out and inaccessible. 

• If Display message box for new alarm points is checked, an Alarm Point Message 
dialog box is displayed for each alarm point. This message box displays information 
about the alarm point. The alarm can be acknowledged from this dialog box, or the 
dialog box can be closed and the alarm acknowledged later. You can also give users 
the ability to change alarm levels and priorities at Runtime.
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II. Examine Alarm Logging Options

From the Logging page, you can configure printer and file alarm logging.
1. Click the Logging tab.

Any printer configured on your PC is displayed in the Selected Printers dialog box. 

2. If you wish to experiment with the print logging feature, select a printer and check Printing 
Enabled.

You can send alarms to additional printers by selecting more than one printer in the Selected 
Printers field.

III. Create an Auditory Alarm

The Sound page configures the alarm sound capabilities. To use these features, your PC must have a 
properly configured sound card and driver to support the desired sound file types. Both WAV and 
MID files are supported.
1. Click the Sound tab.
2. If necessary, browse to the SNAP PAC Learning 

Center directory.

For example, 
C:\Users\Public\Documents\Opto 22\PAC 
Project 9.6\SNAP PAC Learning Center

NOTE: If the Use Project Directory option is selected, 
only the file name needs to be specified. If this 
option is not selected, the path must be included 
with the file name.

3. Double-click the Ahhhhh.wav file.
4. Make sure the option Play sound once when 

any alarm is active is selected. 
5. Click OK.

About Printer Logging

The Selected Printers field displays all 
installed printers. Multiple printers may be 
selected to log alarms. The Column 
Format button displays the Alarm 
Format dialog box. From this dialog box, 
the printed columns can be configured. 
Each column is optional and the width 
can be specified. The Printing Enabled 
check box enables printer logging. The 
File Setup button displays the File 
Access dialog box, used to configure the 
log file’s file name, line format, and rollover 
period. The File Logging Enabled 
check box enables file logging.

Highlighting 
indicates a 
selected printer.
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Testing Alarms

I. Correct Any Alarm Conditions

1. Turn the potentiometer so the tank level is above 2000 gallons.
2. Turn off the Freezer Door switch (Freezer Door Status light should be off ).

II. Launch PAC Display Runtime

1. Select File > Save Project and Load Runtime.
2. Close the Event Log Viewer.

III. Trigger Alarms

1. Slowly turn the Fuel Level potentiometer counter-clockwise, to decrease the tank level. 

When it reaches the value designated as the Lo alarm (the value of Fuel_Low_Limit, set to 1000 
by default), the alarm is recorded in both the summary alarm (the top graphic) and the history 
alarm (the lower graphic).

2. Continue to decrease the Fuel Level, until the LoLo alarm is triggered. 
3. Turn the Fuel Level potentiometer clockwise to increase the tank level so that alarms for this 

point are no longer triggered.

Note that the historic log records when the tank level returns to a “Normal” level. 

4. Click the Close Alarms Window. 

Nothing happens. When you configured the Alarms window, you checked an option box that 
prevents the window from closing while there are active alarms.

5. Click the Acknowledge All button. Notice that the alarms change colors when they are 
acknowledged.

IV. Filter Alarms

1. From the Alarm menu, select Priority Filter, and then 900 And Above. 

With this option selected, only alarms with a priority of 900 or greater will be displayed. Note 
that from the Alarm menu you can also disable all alarms. If you wish to prevent a user from 
enabling/disabling alarms, you can disable this feature in the Configurator. 

2. Turn the Fuel Level potentiometer counter-clockwise to trigger the Lo and LoLo alarm.

With the alarm filter set at 900 and above, only the LoLo alarm is displayed.

3. From the Alarm menu, select Priority Filter, and then All Priority Levels. This will enable alarms 
of any priority level.

4. Turn on the Freezer Door switch and wait 10 seconds. 

An alarm will appear in the alarm summary.

5. Click the Freezer_Door alarm to select it. 
6. Turn off the Freezer Door switch.
7. Click Acknowledge.
8. Click the Acknowledge All button to clear any alarms.
9. Click Close Alarms Window.
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10. Exit PAC Display Runtime.

Configuring Control Engine Alarming
The previous alarms were based on the state of I/O points. But what if your control engine loses 
power, or gets disconnected from the Ethernet hub, or someone temporarily takes the control 
engine off-line to update the PAC Control strategy? You might want your PAC Display operator 
interface to notify you of such events. To create this ability, you need to create a control engine alarm 
point and then add it to your alarm graphics.

I. Add a Control Engine Alarm Point to the Detailed Alarm

1. Double-click the upper alarm graphic.
2. In the Alarm Configuration dialog box, click Add.

3. In the Alarm Points dialog box, Click Add.

This time, you are configuring an alarm point on-the-fly. (You could have first added the alarm 
point using the Configure > Alarm Points menu option, and then added the alarm point to the 
alarm graphic.)

4. In the Name field, type Connection Lost.
5. In the Setup By field, select the Controller Status option.

No alarm points are 
present because all the 
configured alarm points 
have already been added 
to the alarm graphic.

This Add 
button allows 
you to 
configure new 
alarm points.
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II. Choose a Control Engine

1. Click the Control Engines tab.
2. Select SNAP PAC.

Any control engines that have been added to the PAC Display project are shown here. If you want to 
change the Detached by User or Detached on Error priority levels, enter a new value in the 
corresponding field. Using the default settings, these priority levels cannot be filtered out by the 
user since they are higher than 999. If you want the user to be able to filter out control engine status 
alarms, set either—or both—values to 999 or less.
3. Click OK to close the Alarm Point dialog box.

NOTE: If your 
control engine isn’t 
shown, make sure 
Control Engine 
Status, under 
Setup, is selected.
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III. Add a New Alarm Point

1. In the Alarm Points dialog box, select Connection Lost.

2. Click OK to close the Alarm Points dialog box.
3. Click OK to close the Alarm Configuration dialog box.

IV. Add the New Alarm Point to the History Alarm

1. Double-click the lower alarm graphic.
2. In the Alarm Configuration dialog box, click Add.
3. Select Connection Lost.
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4. Click OK to close the Alarm Points dialog box.

5. Click OK to close the Alarm Configuration dialog box.

Configuring a Dynamic Object for Control Engine Status

I. Open the Main Window

Review: 
1. Choose Window > Open.

(This option is disabled when all windows are already open)

2. In the Open Windows dialog box, choose the window.
3. Click OK.

II. Create a Graphic

You will create a graphic that will change color based on the status of the control engine 
connection. This graphic will also launch the View Control Engine dialog box that lets you attach or 
detach the control engine connection.
1. Choose the Rectangle tool.
2. Click and drag a rectangle in the window: 
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III. Assign Control Engine-Driven Attributes

1. Using the Select tool, double-click the rectangle you just created.
2. In the Graphic Dynamic Attributes dialog box, double-click Control Engine Status.
3. In the Dynamic Attribute dialog box, select SNAP PAC.
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4. Change the color fields if desired. By default, the 
button will be light green if the control engine is 
attached, yellow if the control engine is detached 
by the user, red if the control engine is detached 
by an error, and the dynamic objects will be dark 
green to indicate a value is the last known value 
before the control engine connection was lost.

5. Click OK to close the Dynamic Attribute dialog 
box.

Selecting Control Engine Status disables the other control engine-driven attributes. This graphic 
now reflects the Control Engine Status, which is either Attached, Detached by User, or Detached on 
Error.

IV. Create a Text Label

1. Using the Text tool, click in the middle of the rectangle.
2. Type Control Engine Status, and click elsewhere in the window to anchor the text.

V. Format the Text

1. Click the Select tool.
2. Select the text.
3. Right-click the text and choose Style > Bold from the pop-up menu.
4. Select both the text and the rectangle.

5. Right-click the selected objects and choose Align > Center from the pop-up menu.

Review: Changing a Color

Click a color box to open the Colors 
dialog box. In the Color dialog box, you 
can select an existing color or define a 
new one. Open the Color dialog box for 
each color you configure.

Review: Selecting Multiple Objects

With the select tool, click and drag a rectangular 
area around the objects you wish to select. 



ACTIVITY

SNAP PAC Learning Center User’s Guide258

6. Right-click the selected objects again, and choose Align > Middle.
7. Aligning these objects may have moved them.
8. Drag the selected objects or use the arrow keys to move these objects to the desired location 

in your window.

Testing Your Project

I. Correct Any Alarm Conditions

1. Turn the potentiometer so the tank level is above 1000 gallons.
2. Turn off the Freezer Door switch (Freezer Door Status light should be off ).

II. Launch PAC Display Runtime

1. Select File > Save Project and Load Runtime.
2. Click Close to close the Event Log Viewer.

III. Simulate a Control Engine Error
To simulate a control engine error, disconnect the Ethernet cable from the SNAP PAC.

Three things will happen:

• The Event Log Viewer notifies you that the control engine has detached on error.

• Alarms appear in both alarm graphics.

• The dynamic objects turn dark green to indicate that their values are the last known value. (You 
will need to move the Alarms window to see this.)

IV. Restore Connection
Reconnect the Ethernet cable to the SNAP PAC.

PAC Display will automatically restore communications. After a minute or so, three things will 
happen:

• The Event Log View notifies you that the control engine has reattached.

• Messages appear in both alarm graphics.

• The dynamic objects return to their normal colors.

V. Close the Alarm Window and PAC Display

1. Acknowledge any remaining alarms.
2. Click Close Window.
3. Close PAC Display Runtime.
4. Close PAC Display Configurator.

Summary
Dynamic graphics, SuperTrends, and Alarms are three commonly used components of PAC Display. 
There are many other features to discover on your own:
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• Additional dynamic attributes—You haven’t used all of the dynamic attributes available. 
You may wish to experiment with the operator-driven attributes that manipulate an objects 
visibility and position on the screen. These features are useful for creating elaborate animation 
using graphics drawn in PAC Display or graphics created in other illustration programs.

• Additional graphical objects—You may wish to use table graphics to display the values of 
numeric table variables used in your PAC Control strategies.

• Recipe files—Text-based recipe files can write to variables in your PAC Control strategy. The 
capabilities of the operator’s interface are greatly extended by creating recipe files that can be 
downloaded from PAC Display.

• System architecture options—In an industrial network, you may wish to use a dedicated 
server for data management and storage of SuperTrend data. You can designate remote 
computers for these tasks. 

This last option includes using OptoOPCServer running on a dedicated server. This configuration is 
recommended for applications where multiple seats of PAC Display are monitoring a process. 
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Appendix A

Appendix

Road Map
The following pages present a graphical overview of the PAC Control strategy and PAC Display 
project developed in the SNAP PAC Learning Center guide.

All components of the strategy are listed on the left side. The chapters of this guide are represented 
as columns. Follow a horizontal path to the right of each component to see where in the lessons the 
component is introduced, used, and modified. This overview also shows which components affect 
subsequent chapters (for example, which PAC Control components are critical to the PAC Display 
project).
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