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1: 1: Installing the OptoEMU1Chapter 1

1: Installing the OptoEMU1

Introduction
This guide shows you how to install and use an Opto 22 Energy Monitoring Unit (OptoEMU1), part 
number SNAP-IT-EMU1. 

The OptoEMU1 lets you monitor energy usage for a three-phase electrical device—for example, air 
conditioning and heating unit, compressor, or electric motor—so you can anticipate energy bills 
and respond quickly when energy use rises unexpectedly.

The unit includes a sample monitoring program and an HMI, both of which you can modify or use as 
an example for your own application. Complete software and documentation are included. 

Hardware is also expandable. If you need to monitor additional devices or to control devices, you can 
add more I/O modules to the rack. For information about available modules, visit our website 
(www.opto22.com) or contact Pre-sales Engineering (phone 800-321-6786 or email 
systemseng@opto22.com). 

For Help

If you have trouble installing or using the OptoEMU1 and cannot find the help you need in this guide 
or on our website (www.opto22.com), please contact Opto 22 Product Support.

Phone: 800-TEK-OPTO (835-6786)
951-695-3080
(Hours are Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

NOTE: Email messages and 
phone calls to Opto 22 
Product Support are 
grouped together and 
answered in the order 
received. 

http://www.opto22.com
http://www.opto22.com
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Installing the Unit
The OptoEMU1 includes the following hardware, pre-wired in a sturdy polycarbonate industrial 
enclosure:

• SNAP-PAC-R2 programmable automation controller

• SNAP-AIPM-3 analog input module

• Power supply

• Mounting rack (with three unused slots for expansion)

What You Will Need

You’ll need the following items to install the OptoEMU1 unit:

• OptoEMU1 unit (provided)

• 100–240 VAC power on a dedicated circuit breaker

• Wire and fuses as required by the wiring diagram you are using (see page 4)

• Current transformers appropriate for the device you are monitoring

• Category 5 or better solid UTP cable with RJ-45 connector to a 10/100 Mbps Ethernet network

• Four #8 screws for attaching the unit to the wall (Screw type depends on wall material and 
construction.) 

• Standard screwdrivers (large and small). Depending on the installation, additional tools may be 
needed.

NOTE: The OptoEMU1 can monitor devices using 85–250 volts and 0–10 amps, and it can also monitor 
AC line currents greater than 10 amps using a standard current transformer (CT) of suitable ratio. For line 
voltage higher than 250 VAC, use a step-down potential transformer. If hazardous voltage or current is to 
be monitored, an interposing potential transformer and a CT must be used for safety.

Attaching the Unit to the Wall

1. Remove the OptoEMU1 unit from its packaging. 

NOTE: Dimensional drawings are on page 18.

2. Using a standard screwdriver, unscrew the four screws in the unit’s cover and take off the cover. 
Save the screws.

3. Notice the parts of the unit, shown below. The SNAP PAC controller and the I/O module are 
mounted on the rack. The AC power inlet is at the bottom of the unit. Mounting holes are 
located at each corner. 
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4. Find a wall location that’s convenient for monitoring the device. Make sure there is space on at 
least two sides for ventilation (preferably top and bottom).

5. Using four #8 screws suitable for the wall’s construction, mount the unit to the wall through the 
same corner holes used to attach the cover. (See dimensional drawings on page 18.)

An alternative method is to unscrew the hardware panel from the box and use the secondary 
mounting holes at the back of the box to attach the unit to the wall; then replace the panel.

Wiring the Module

As the diagram shows, the OptoEMU1 unit contains one SNAP I/O module, a SNAP-AIPM-3. 

1. Remove a convenient knockout. Run the wires from the device being monitored, through the 
knockout hole, and into the unit. Use a strain-relief connector if needed. 

2. Wire the module to the device using the diagram on the following page. 

Controller Module Rack

Corner mounting hole

Power supply

AC power inlet
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Three-Phase Wiring to SNAP-AIPM-3 Module

CAUTION: The SNAP-AIPM-3 module does not contain a fuse. 
Protect the system by adding a fuse. 

Suggested vendors
Protection fuses: http://www.littelfuse.com
Voltage and current transformers: http://www.crmagnetics.com

WARNING! Disconnect power upstream from unit 
when wiring or servicing to avoid potential shock 
hazard. This unit must be on its own circuit breaker.

CAUTION: Be very careful when connecting input channels. Do 
not connect line voltage to the current input channel; such 
a connection will cause severe damage to the module. This 
damage is not covered by warranty. Use a current transformer 
instead. 

CAUTION: Use caution when selecting wire gauges for your appli-
cation. Use conservative wire gauges with proper voltage ratings.

CAUTION: Terminals 2 and 3 share a common connection inside 
the module. Make sure you observe polarity when connecting 
the second channel. To avoid a potentially hazardous short circuit, 
double-check wiring before turning on the current to be 
monitored.
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Applying Power to the Unit

WARNING: Install the unit on a dedicated circuit breaker so power can be turned off for maintenance. The 
unit itself does not have a power switch.

1. Run 100–240 VAC power from a dedicated circuit breaker through the AC power inlet and wire 
it to the power supply. 

2. If necessary, provide strain relief for the power cord. 

Finishing Installation

1. If the OptoEMU1 unit is mounted in an area with high air temperature, provide ventilation for 
the unit by removing four unused knockouts on the box, preferably two at the bottom and two 
at the top. Place a black nylon vented finishing plug (provided) in each hole.

2. Plug a standard Category 5 or better solid UTP cable with an RJ-45 connector into the Ethernet 1 
network interface on the controller. Connect the cable to the 10/100 Mbps Ethernet network 
that will be used for monitoring. 

3. Notice the white label on the side of the controller. Write down the MAC address (MAC 1 only), 
as you will need it later to assign the unit an IP address. After you assign the IP address, you will 
write it on this label for future reference. 

Configuring the Unit

Installing Software

Software requirements:

• Computer with at least the minimum processor required for your version of Microsoft® 
Windows® (single or dual core, 1 GHz Pentium®-class or better recommended) and Ethernet 
capability, on the same subnet as the OptoEMU1.

• Windows Vista® Business (32-bit), Windows XP Professional (with SP2 or higher) or Windows 
2000® (with SP4) workstation operating system. Microsoft Windows server, 64-bit versions of 
Windows workstation, and embedded operating systems are not supported. 

• At least 1 GB RAM for Windows Vista, or at least 512 MB for Windows XP or Windows 2000. 

• VGA or higher resolution monitor (Super VGA recommended), minimum size 1024 x 768. 

• Mouse or other pointing device. Printer optional. 

• Available hard disk space required: 124 MB 

1. If PAC Project is not yet installed on a PC on the same network segment as the OptoEMU1, put 
the PAC Project Software Suite CD into the CD-ROM drive. Installation should begin 
automatically. If it does not, navigate to the CD and double-click Setup.exe to begin. 
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2. When PAC Project is installed, remove its CD from the CD-ROM drive and insert the OptoEMU1 
Samples CD. Again, installation should begin automatically, or you can navigate to the CD and 
double-click Setup.exe to begin.

PAC Project Basic software and the sample control and HMI programs are now installed. You can 
configure the OptoEMU1, use the HMI, and modify the sample programs for your application.

Default file locations:

• PAC Project Software Suite: Programs/Opto 22/PAC Project/

• OptoEMU1 sample files:  Programs/Opto 22/OptoEMU1/

Assigning an IP Address to the OptoEMU1

When you first turn on the OptoEMU1, it sends out a BootP broadcast requesting an IP address. You 
must assign the OptoEMU1 a unique, fixed IP address so you can communicate with it on your 
network. Work with your network administrator to determine the IP address and subnet mask to use. 

If the network you’re using has a Dynamic Host Configuration Protocol (DHCP) server, either assign a 
static IP address before connecting the OptoEMU1 to the network (preferred), or disable the server. 
(If you don’t, the DHCP server may respond to the BootP request and assign a dynamic address.)

NOTE: To make sure the controller or I/O unit is not on a network with a DHCP server, we recommend you 
use a crossover cable with a direct connection. If you connect directly to a PC that is normally on a DHCP 
network, you must assign a fixed IP address to the PC’s network card (NIC) in order to communicate.

Also, since BootP broadcasts cannot get through a firewall in the PC, disable any firewall (such as the 
built-in firewall in Windows XP). Firewalls in a router should not be a problem.

1. Have handy the OptoEMU1’s MAC 1 address, which you wrote down from the label on the side 
of the controller.

2. On the PC’s Start menu, choose Programs > Opto 22 > PAC Project > PAC Manager.
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The PAC Manager main window opens.

3. From the Tools menu, choose Assign IP Address.

4. Apply power to the OptoEMU1 by switching its circuit breaker to ON.

The following dialog box opens on the PC. Any Opto 22 Ethernet-based devices without IP 
addresses that are on the PC’s network segment appear in the list of units requesting IP 
addresses.
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5. In the list, double-click the MAC 1 address of the OptoEMU1.

6. Enter the IP Address and the Subnet Mask for the device. If it will be talking to a device on 
another subnet, enter the Gateway (router) address. If it will talk only on the local subnet, leave 
the gateway address all zeros (0.0.0.0). Leave the DNS address at 0.0.0.0 and the Host Name 
field blank.

CAUTION: Each device on your network, including computers, routers, controllers, brains, and so on, 
must have a unique IP address. Failure to assign unique IP addresses may cause catastrophic network 
or hardware failures. If you don’t know which IP addresses are safe to use, check with your system 
administrator.

7. When all fields are correct, click OK. 

The new IP address information appears in the upper list in the dialog box, and the device’s 
status changes to Mapped. The address information also appears in the lower list. 

8. With the device still highlighted, click Assign. 

The address is saved to flash memory, and the status changes to Static IP. 

9. To verify that the IP address has been successfully assigned, highlight the device in the upper 
list and click Test.

A DOS window opens and the IP address is automatically contacted using the PING program. 
You should see a reply similar to the following:
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If you don’t see a reply, make sure the subnet mask you’ve assigned matches the subnet mask 
on your PC.

10. For future reference, write the IP address next to the MAC address on the white sticker inside 
the OptoEMU1. 

11. Using the OptoEMU1’s original four corner screws, replace the unit’s cover. 

12. On the PC, close PAC Manager.

Configuring the Controller

1. Open Windows Explorer and navigate to C:\Program Files\Opto 22\OptoEMU1\Power Monitor 
Strategy. Double-click Power Monitor Strategy.idb to open the control program (called 
a strategy). 

2. In the Strategy Tree, double-click the Control Engines folder. Click Add twice to get to the 
Control Engine Configuration dialog box shown below:

Strategy Tree

Control Engines
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3. In the Control Engine Name field, type: PM Engine

4. In the Primary IP address field, type the IP address you just assigned to the OptoEMU1. Leave 
the other Settings as they are. Click OK.

5. Make sure that PM Engine is highlighted and click OK again (twice) to return to the main 
window.

Scaling Points on the SNAP-AIPM-3

To make sure values appear correctly in the HMI, you must alter the scale for points on the 
SNAP-AIPM-3 module to match the inputs and ratio of the current transformer (CT) you use. The 
examples below will help you determine the correct values for your CT; then follow the steps on 
page 12 to enter them.

Important: For all installations of 85 to 250 VAC, both Actual and Scaled Volts remain at 0–250 VAC. 
For installations over 250 VAC (such as lighting systems using 277 volts), you will need to scale volts, 
however. See “Scaling Example 3*” on page 12. 
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Scaling Example 1

Scaling Example 2

CT primary CT sec CT ratio

250 5 50

Points 0, 4, 8 Points 1, 5, 9

Actual Scaled Actual Scaled

Unit VAC/VDC VAC/VDC A A

Lower 0 0 0 0

Upper 250 250 5 250

Points 2, 6, 10 Points 3, 7, 11

Actual Scaled Actual Scaled

Unit W W VA VA

Lower 0 0 0 0

Upper 2500 125000 2500 125000

Points 12 & 13 

Actual Scaled

Unit J J

Lower 0 0

Upper 7500 375000

CT primary CT sec CT ratio

50 5 10

Points 0, 4, 8 Points 1, 5, 9

Actual Scaled Actual Scaled

Unit VAC/VDC VAC/VDC A A

Lower 0 0 0 0

Upper 250 250 5 50

Points 2, 6, 10 Points 3, 7, 11

Actual Scaled Actual Scaled

Unit W W VA VA

Lower 0 0 0 0

Upper 2500 25000 2500 25000

Points 12 & 13 

Actual Scaled

Unit J J

Lower 0 0

Upper 7500 75000
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Scaling Example 3*

1. In the Strategy Tree, click the plus sign next to the I/O Units folder to open it. Also click the plus 
signs next to PM_Module and Points.

2. Double-click Amps_A to open the Edit Analog Point dialog box.

CT primary CT sec CT ratio

400 10 40

Points 0, 4, 8 Points 1, 5, 9

Actual Scaled Actual Scaled

Unit VAC/VDC VAC/VDC A A

Lower 0 0 0 0

Upper 138.5 277 10 400

Points 2, 6, 10 Points 3, 7, 11

Actual Scaled Actual Scaled

Unit W W VA VA

Lower 0 0 0 0

Upper 2500 100000 2500 100000

Points 12 & 13 

Actual Scaled

Unit J J

Lower 0 0

Upper 7500 300000

* Note that this example of line voltage 
higher than 250 VAC requires the use of a 
step-down potential transformer. 

If hazardous voltage or current is to be 
monitored, an interposing potential 
transformer and a CT must be used for 
safety.
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3. In the Scaling area, enter the correct Actual and Scaled values for your CT.

For “Scaling Example 1” on page 11, you would enter 5 for Actual Upper and 250 for Scaled 
Upper. 

4. Click OK.

5. Repeat step 2 through step 4 for all the points that need scaling. (For Example 1, that would be 
all points except Volts A, B, and C. The last two points are True Power in joules).

Downloading the Strategy to the Controller

1. From the Mode menu, choose Debug to download the strategy to the OptoEMU1. Click Yes or 
OK in response to all messages. 

The strategy is loaded and saved to flash memory. In case of power loss, the strategy will 
automatically start running again when power is restored.

2. Once the strategy is downloaded, choose Debug > Run or click the Run button .

The control strategy begins running on the OptoEMU1. Since it runs independently from the 
PC, you can close PAC Control. Or, if you want to see how the strategy works, you can leave it 
open and look at the flowcharts and elements in the Strategy Tree. 

The PAC Control Basic software installed on your PC is a fully operational version that you can 
use to modify or expand the control strategy to fit your application. The PAC Control User’s Guide 

Enter actual and scaled 
values here.
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and the PAC Control Command Reference give you complete documentation; choose Start > 
Programs > Opto 22 > PAC Project > Manuals to open the PDFs.

Launching the Sample HMI

1. In Windows Explorer, navigate to C:\Program Files\Opto 22\OptoEMU1\Power Monitor Display. 
Double-click Power Monitor Display xp.UUI to open the HMI program. 

The file opens in PAC Display Configurator, which is the development application; later you will 
use it in PAC Display Runtime, which is the operator interface application.

2. At the message saying it can’t find the strategy file, click OK. 

The Control Engines dialog box opens:

3. Highlight PM Engine and click Modify. 
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4. Click the Browse button next to PM Engine. In the Select Control Engine dialog box, highlight 
PM Engine and click OK. 

5. Click the Browse button next to Strategy. If you see a message about tags becoming invalid, 
click Yes to continue. Navigate to C:\Program Files\Opto 22\OptoEMU1\Power Monitor 
Strategy\Power Monitor Strategy.idb and open this strategy file. Click OK twice to return to the 
PAC Display main window.

Setting Graphic Scales

Just as you set scaling for the points in the strategy, now you need to change the scale of the HMI 
graphics to match your configuration. You’re in the PAC Display Configurator main window:

PM Engine browse

Strategy browse
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1. Double-click in the center of the graph at the upper left (the one that says kWh in yellow).

2. Click the Pens 1-8 tab.

3. Next to the first pen (3Phase, the yellow one), click the Modify button.
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4. In the Range area, enter the same scaled values you entered for this point in PAC Control. Then 
click OK.

5. Repeat step 4 for the other three pens shown. Then click OK to go back to the main window. If a 
message asks if you want to keep these settings, click Yes.

6. Back in the Monitoring window, double-click the Watts graph and repeat steps 2 through 5.

You’ve now scaled the Monitoring window graphs. The other two windows also need to be 
scaled.

7. In the Monitoring window, choose Window > Power to open the Energy Detail window. 
Double-click each of the three graphs in this window and repeat steps 2 through 6.

8. When you’ve finished the Energy Detail (Power) window, choose Window > kWh to open the 
kWh Detail window. Again, double-click each graph and repeat steps 2 through 6. 

All HMI graphs should now match your application.

9. Choose File > Save Project and Load Runtime. At the message about regenerating IO Scanner 
tag names, click OK.

Initial setup is finished, and PAC Display Runtime Basic opens in front of PAC Display 
Configurator, showing the sample HMI for the OptoEMU1. You can close Configurator (the one 
in back), but leave Runtime (the one in front) open. Continue with Chapter 2 to learn how to 
use the HMI. 

Change values here to match 
points in PAC Control.
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Dimensional Drawings

NOTE: To avoid having to remove the 
hardware panel, just remove the 
cover and use #8 screws in the 
corner holes for mounting. See 
directions on page 3.

Applicable dimensions for these 
mounting holes are circled at left.

WARNING!

Disconnect power upstream from unit when 
wiring or servicing to avoid potential shock hazard.

This unit must be on its own circuit breaker.
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Specifications

Overall Unit

Power Requirements 100–240 VAC, 0.6 A

Communication 10/100 Mbps Ethernet network interface (RJ-45 connector)

Backup battery
Rechargeable (recharges whenever the unit has power), 3-year power-off 
data retention

Operating Temperature 0 to 60 °C

Storage Temperature -40 to 85 °C 

Humidity 0–95% humidity, non-condensing

Enclosure NEMA Type 4X polycarbonate

SNAP-AIPM-3 Voltage inputs (each input)

Recommended Input Range 85 to 250 VAC RMS

Input Over Range To 275 volts

Maximum Input 300 V 

Input Resistance – Single 
Ended

1 Megohm (NOTE: Because both channels share the same reference termi-
nal, polarity must be observed when connecting the current channel.)

SNAP-AIPM-3 Current Inputs (each input)

Input Range 0 to 10 AC amps RMS

Input Over Range To 11 amps (Reading is not reliable over 11 A.)

Maximum Input 15 A continuous

AC Common Mode Rejection > – 120 dB at 60 Hz

Maximum Operating Common 
Mode Voltage

250 VAC

Input Resistance – Single 
Ended

0.005 Ohm (NOTE: Because both channels share the same reference termi-
nal, polarity must be observed when connecting the voltage channel.)
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2: 2: Monitoring DevicesChapter 2

2: Monitoring Devices

Using the Main Window
NOTE: The sample HMI is designed to fully fit a monitor with a 1000 x 720 screen. 

1. If the sample HMI is not already running, from the Start menu choose Programs > Opto 22 > 
PAC Project > PAC Display Runtime Basic. 

2. If the HMI does not start running immediately, choose File > Open Project and navigate to the 
HMI (default location: C:\Program Files\Opto22\OptoEMU1\Power Monitor Display). Highlight 
Power Monitor Display xp.UUI and click Open.

The OptoEMU1 Monitoring window opens:

3. Since the OptoEMU1 begins recording data right away, click the Sync to PC Time/Date button in 
the bottom-right corner of the window to synchronize the OptoEMU1 with the computer. 
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The Monitoring window has three panels: kWh and Watts at the top, and Alarm at the bottom.

• Use kWh and Watts to monitor current energy usage (kilowatt-hours and true power). 

• Use Alarm to define, view, and acknowledge alarms. (See “Setting Up Alarms” on page 27.)

Viewing Current Energy Usage

The kWh and Watts panels show current energy usage. Data is updated every second. The value at 
the upper right always reflects 3-phase data. The kWh panel is shown below as an example; the 
Watts panel works in the same way.

If you don’t see all four lines, you may want to change the scale on the graph. 

1. To change the scale on the graph, click the down arrow and choose the line for the data you 
want. 

Yellow = Sum of phases A, B, and C
Orange = Phase A
Green = Phase B
Red = Phase C

2. Click the Scale button . Enter the scale values you want and click OK.

NOTE: This scale change applies only to the data for the line you’ve chosen. 

3. For more, click the Detail button in the panel. For the kWh panel, see “Viewing Historical kWh 
Data,” below. For the Watts panel, see “Viewing Historical Energy Data” on page 25. 

Current value of 3-Phase data 

Time and date

Data that scaling applies to (click 
down-arrow to choose other data)

Click to change scale

Visual representation of all 
four data points



Opto 22 Energy Monitoring Unit Quick Start Guide 2323

Viewing Historical kWh Data

Historical data is automatically saved on the PC. Here’s how to view that data.

1. In the Monitoring window, click the Detail button in the kWh panel.

This window shows a panel for each of the three phases plus the sum. You can also get 
historical data from this window.

2. To see the total kWh for each hour within the most recent 24-hour period, click the 24 Hr 
Record button. 

New data appears at the top of the table at index zero, at the end of the hour. To widen a 
column to fit the data, put your cursor on the right-hand edge of the column’s title. When the 
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cursor changes to a plus sign, click and drag the column to the width you want. Click Close 
when finished.

3. To see historical data for one of the phases or the sum, click its historical trend button .

4. Highlight the log file or files you want to see and click OK. For multiple files, click the first file, 
hold down the SHIFT key, and click the last file. For non-contiguous files, hold down the CTRL key 
while you click each file.

The graph changes from current data to historical data.

5. Use the button bar to work with the historical trend graph:

6. To see the value, time, and date at any point on the graph, click that point. 

Beginning 
of log file

Back one screen

Forward one screen

Back one major division

Forward one major division End of log file

Zoom in

Normal view

Zoom out

Historical data

Real-time data
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7. To change back to real-time data, click the Real-time button  .

8. To go back to the Monitoring window, click the Back button in the upper-left corner of the 
window.

Viewing Historical Energy Data

1. In the Monitoring window, click the Detail button in the Watts panel.

The Energy Detail window opens. 

Data point you clicked. 
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The two graphs at top show Volts and Current for each of the three phases, with color-coded 
numeric values. The bottom graph is a larger version of the Watts graph from the main window, 
also with color-coded numeric values for True Power and Power Factor. 

You can also access historic logs from this window.

2. To find the peak kilowatt usage of the day, click the Peak Usage button at the bottom right. 

A small dialog box opens showing the peak plus the time and date it happened. 

3. To reset the value for your next observation, click Reset Peak. Then click Close.

4. To see historical data for a graph, click its historical trend button  and follow the same 
steps you used for the kWh graph (see page 24).

NOTE: If you click a point on the graph to see the value at that time and date, the value you see is for 
the line listed. To see the data point for a different line (Phase B, for example), click the down arrow 
and choose the line you want.

5. To return to the Monitoring window, click the Back button at the upper-left corner.

Data point you clicked. Data is for 3 Phase.

To see data for a different line, click the down arrow and 
choose the line. Then click the point on the graph.
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Using Alarms and Email Notification
Once you’ve monitored energy usage for a short while, you’ll want to do more:

• Set up alarms you can see and acknowledge in the main Monitoring window.

• Define normal usage and set up email notification if usage is abnormal.

Setting Up Alarms

Alarms are set up in the Alarm panel of the Monitoring window. In the sample HMI, you will not 
receive email messages for alarms; instead, they appear in this window and can be acknowledged 
from here.

Alarms are based on Current kWh of the three phases. You can set up four alarms:

• HiHi alarms occur when the Current kWh value reaches or exceeds the HiHi value.

• Hi alarms occur when the Current kWh value reaches or exceeds the Hi value but is less than the 
HiHi value.

• Lo alarms occur when the Current kWh value is equal to or less than the Lo value but greater 
than the LoLo value.

• LoLo alarms occur when the Current kWh value is equal to or less than the LoLo value.

 

1. To set up alarms, click the numeric value field for the alarm you want to define.

2. Enter the value for the alarm and click OK. Repeat for any other alarms you want to set.
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Viewing and Acknowledging Alarms

When an alarm occurs, it is listed in the Monitoring window:

If you cannot see all the data, change the width of the columns to fit, or scroll to the right.

To acknowledge an alarm, highlight it and click the Acknowledge button. The alarm listing turns to 
pale orange. 

Defining Expected Energy Use and Email Notification

If the device’s energy use increases faster than expected, the OptoEMU1 can email an alarm to 
someone. Follow these steps to define expected energy use and set up the email address.

1. In the Monitoring window, click the Email Setup button in the upper left.

2. Complete the Setup dialog box as follows.

Name Of Devices Enter a name for the device you’re monitoring.

IP Address of Email 
Server

Enter the IP address of the email server that the OptoEMU1 will use to send 
the email. If you don’t know the IP address, ask your network administrator. 
NOTE: The server must not require a password or authentication.

Email Address to 
Send To

Enter the email address of the person who will receive the email (example: 
jsmith@yourcompany.com)

Alarm
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3. When you’ve finished entering information, click Close to return to the Monitoring window.

When an email is sent, the Monitoring window changes panel titles to red and shows the email in 
the Alarm panel:

To clear the notice and return the window to normal, click the green check mark.

From - Email Address
Enter a name that tells the person who receives the email where it is coming 
from (example: generator1). The email automatically includes the name of the 
device and date and time of the event.

kWh Setpoint

Enter a setpoint in kilowatt hours. This setpoint is the normal electrical energy 
use you expect from this device. Actual use above or below this value prompts 
the OptoEMU1 to calculate the change in kWh every second. If you don’t 
know the normal energy use, watch it for awhile in the Monitoring window.

Max kWh Change
Enter the normally expected rise in energy use for this device, in kWh. Again, 
if you don’t know the value to use, watch the energy usage change over time 
to see what is normal. 

Email 
notice
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What’s Next?
Now that you’ve gotten started with the sample control strategy and HMI, you’ll probably want to 
adapt them to suit your own needs. All the tools to do so are readily available. The PAC Project Basic 
software included with your OptoEMU1 is a full version with complete documentation, and the 
OptoEMU1 unit is expandable.

• To change the HMI, choose Start > Programs > Opto 22 > PAC Project > PAC Display 
Configurator Basic. You can save the Power Monitor project file under a new name, play with it, 
and change it as you wish. For help, see the PAC Display User’s Guide (in Start > Programs > 
Opto 22 > PAC Project > Manuals). 

• To monitor additional equipment or to control devices, add the I/O modules required. 
For descriptions and specifications, see our website, www.opto22.com (click the Products tab, 
choose SNAP PAC System, and then choose Brains and I/O). A wide range of analog, digital, and 
serial I/O modules is available. You can add more modules to the OptoEMU1, and you can also 
add additional racks, brains, and I/O for an extended system, all controlled by the OptoEMU1’s 
controller. 

If you have questions about which products to use, contact our Pre-sales Engineers by phone 
(800-321-6786 or 951-695-3000) or by email (systemseng@opto22.com). 

• To modify the control strategy, choose Start > Programs > Opto 22 > PAC Project > PAC 
Control Basic. Save the strategy in a new folder under a new name. Explore the Strategy Tree, 
which lists all the elements in the strategy—control engines, flowcharts, all kinds of variables, 
and all the I/O points. Also take a look at the flowcharts; they are largely self-documenting, so 
you can see what they do and how the logic flows. For help in using PAC Control, see the PAC 
Control User’s Guide and the PAC Control Command Reference (to open the PDFs, choose Start > 
Programs > Opto 22 > PAC Project > Manuals). 

• Free training on PAC Control and PAC Display is available at our headquarters in Temecula, 
California. See http://www.opto22.com/site/training.aspx for more information, or call 
800-321-6786 and ask for Training.

• Free product support is included with your OptoEMU1. See “For Help” on page 1 for contact 
information. 

http://www.opto22.com/site/pr_selector.aspx?cid=1&qs=1003
http://www.opto22.com/site/training.aspx
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